[PATCH 06/18] drm: use ARRAY_SIZE
Jani Nikula
jani.nikula at linux.intel.com
Mon Oct 2 07:43:18 UTC 2017
On Sun, 01 Oct 2017, Jérémy Lefaure <jeremy.lefaure at lse.epita.fr> wrote:
> Using the ARRAY_SIZE macro improves the readability of the code. Also,
> it is not always useful to use a variable to store this constant
> calculated at compile time nor to re-invent the ARRAY_SIZE macro.
>
> Found with Coccinelle with the following semantic patch:
> @r depends on (org || report)@
> type T;
> T[] E;
> position p;
> @@
> (
> (sizeof(E)@p /sizeof(*E))
> |
> (sizeof(E)@p /sizeof(E[...]))
> |
> (sizeof(E)@p /sizeof(T))
> )
>
> Signed-off-by: Jérémy Lefaure <jeremy.lefaure at lse.epita.fr>
Please split this up.
Patch 1:
> drivers/gpu/drm/amd/amdgpu/gfx_v8_0.c | 9 +++++----
> drivers/gpu/drm/amd/amdgpu/gfx_v9_0.c | 9 +++++----
Patch 2:
> drivers/gpu/drm/gma500/psb_intel_sdvo.c | 9 ++++-----
Patch 3:
> drivers/gpu/drm/i915/gvt/vgpu.c | 3 ++-
Patch 4:
> drivers/gpu/drm/nouveau/nvkm/subdev/bios/init.c | 7 ++++---
Patch 5:
> drivers/gpu/drm/via/via_verifier.c | 10 ++++------
BR,
Jani.
--
Jani Nikula, Intel Open Source Technology Center
More information about the dri-devel
mailing list