[PATCH 11/12] sched: use for_each_if in topology.h
Peter Zijlstra
peterz at infradead.org
Mon Jul 9 10:36:56 UTC 2018
On Mon, Jul 09, 2018 at 10:36:49AM +0200, Daniel Vetter wrote:
> Avoids complaints from gcc about ambiguous else clauses.
Is that a new thing? I'm fairly sure I've never seen it do that,
> Signed-off-by: Daniel Vetter <daniel.vetter at intel.com>
> Cc: Andrew Morton <akpm at linux-foundation.org>
> Cc: Peter Zijlstra <peterz at infradead.org>
> ---
> include/linux/topology.h | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/include/linux/topology.h b/include/linux/topology.h
> index cb0775e1ee4b..4fba5a5b148d 100644
> --- a/include/linux/topology.h
> +++ b/include/linux/topology.h
> @@ -40,7 +40,7 @@
>
> #define for_each_node_with_cpus(node) \
> for_each_online_node(node) \
> - if (nr_cpus_node(node))
> + for_each_if (nr_cpus_node(node))
Not having gotten any of the other patches, I'm not really sure what
this does and such, but improve readability it does not :/
More information about the dri-devel
mailing list