[Bug 107781] amdgpu hangs on resume on Lenovo A475

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Mon Sep 3 10:34:30 UTC 2018


--- Comment #4 from Alex Findler <walthervondervogelweide at gmx.de> ---
I've tried with all kernels that Fedora offered during the last two months,
including 4.16 varieties. 

These are the kernel options I tried:
radeon.cik_support=0 amdgpu.cik_support=1 scsi_mod.scan=sync
amdgpu.gpu_recovery=1 amdgpu.dc=1

I have now added the option iommu=soft, and it seems to solve the problem! I
have tried suspend via script (echo mem > /sys/power/state), via hardware
button, and via plasmashell option, and all come back, including wake-up by lid
signal. I'll test this for a couple of days now and see if it works
persistently, then report back. 

Thanks for your quick reaction, it is much appreciated.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.freedesktop.org/archives/dri-devel/attachments/20180903/afa6520b/attachment.html>

More information about the dri-devel mailing list