[pull] amdgpu drm-next-5.2
Alex Deucher
alexdeucher at gmail.com
Fri Apr 19 15:00:34 UTC 2019
Hi Dave, Daniel,
More updates for 5.2:
- Add the amdgpu specific bits for timeline support
- Add internal interfaces for xgmi pstate support
- DC Z ordering fixes for planes
- Add support for NV12 planes in DC
- Add colorspace properties for planes in DC
- eDP optimizations if the GOP driver already initialized eDP
- DC bandwidth validation tracing support
The following changes since commit ecc4946f11a07884f230450a6d5a92337bc21375:
Merge branch 'drm-next-5.2' of git://people.freedesktop.org/~agd5f/linux into drm-next (2019-04-12 14:46:58 +1000)
are available in the Git repository at:
git://people.freedesktop.org/~agd5f/linux drm-next-5.2
for you to fetch changes up to f55be0be5b7296e73f1634e2839a1953dc12d11e:
drm/amd/display: Add profiling tools for bandwidth validation (2019-04-15 00:22:19 -0500)
----------------------------------------------------------------
Anthony Koo (2):
drm/amd/display: Add switch for Fractional PWM on or off
drm/amd/display: Read eDP link settings on detection
Aric Cyr (1):
drm/amd/display: 3.2.26
Christian König (1):
drm/amdgpu: fix old fence check in amdgpu_fence_emit
Chunming Zhou (2):
drm/amdgpu: add timeline support in amdgpu CS v3
drm/amdgpu: update version for timeline syncobj support in amdgpu v2
David Francis (1):
drm/amd/display: Handle get crtc position error
Joshua Aberback (2):
drm/amd/display: Add fast_validate parameter
drm/amd/display: Add profiling tools for bandwidth validation
Jun Lei (1):
drm/amd/display: expand plane caps to include fp16 and scaling capability
Nicholas Kazlauskas (11):
drm/amd/display: Expose support for NV12 on suitable planes
drm/amd/display: Add DRM color properties for primary planes
drm/amd/display: Update plane scaling parameters for fast updates
drm/amd/display: Maintain z-ordering when creating planes
drm/amd/display: Recalculate pitch when buffers change
drm/amd/display: Rework DC plane filling and surface updates
drm/amd/display: Add basic downscale and upscale valdiation
drm/amd/display: Use surface directly when checking update type
drm/amd/display: Don't warn when DC update type > DM guess
drm/amd/display: Check scaling info when determing update type
drm/amd/display: Relax requirements for CRTCs to be enabled
Samson Tam (1):
drm/amd/display: change name from dc_link_get_verified_link_cap to dc_link_get_link_cap
Yongqiang Sun (1):
drm/amd/display: define HUBP_MASK_SH_LIST_DCN for Raven
shaoyunl (2):
drm/powerplay: Add smu set xgmi pstate interface
drm/amdgpu: Set proper function to set xgmi pstate
drivers/gpu/drm/amd/amdgpu/amdgpu.h | 10 +-
drivers/gpu/drm/amd/amdgpu/amdgpu_cs.c | 152 ++++-
drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c | 3 +-
drivers/gpu/drm/amd/amdgpu/amdgpu_fence.c | 24 +-
drivers/gpu/drm/amd/amdgpu/amdgpu_xgmi.c | 13 +-
drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c | 745 +++++++++++++--------
drivers/gpu/drm/amd/display/dc/calcs/dcn_calcs.c | 24 +-
drivers/gpu/drm/amd/display/dc/core/dc.c | 2 +-
drivers/gpu/drm/amd/display/dc/core/dc_link_dp.c | 33 +-
drivers/gpu/drm/amd/display/dc/core/dc_resource.c | 6 +-
drivers/gpu/drm/amd/display/dc/core/dc_stream.c | 3 +-
drivers/gpu/drm/amd/display/dc/dc.h | 85 ++-
drivers/gpu/drm/amd/display/dc/dc_link.h | 2 +-
drivers/gpu/drm/amd/display/dc/dce/dce_abm.c | 18 +
.../drm/amd/display/dc/dce100/dce100_resource.c | 22 +-
.../drm/amd/display/dc/dce110/dce110_resource.c | 41 +-
.../drm/amd/display/dc/dce112/dce112_resource.c | 22 +-
.../drm/amd/display/dc/dce112/dce112_resource.h | 3 +-
.../drm/amd/display/dc/dce120/dce120_resource.c | 19 +-
.../gpu/drm/amd/display/dc/dce80/dce80_resource.c | 22 +-
drivers/gpu/drm/amd/display/dc/dcn10/dcn10_hubp.h | 9 +-
.../gpu/drm/amd/display/dc/dcn10/dcn10_resource.c | 20 +-
drivers/gpu/drm/amd/display/dc/inc/core_types.h | 3 +-
drivers/gpu/drm/amd/display/dc/inc/dcn_calcs.h | 3 +-
drivers/gpu/drm/amd/powerplay/inc/amdgpu_smu.h | 4 +
drivers/gpu/drm/amd/powerplay/smu_v11_0.c | 9 +-
include/uapi/drm/amdgpu_drm.h | 8 +
27 files changed, 944 insertions(+), 361 deletions(-)
More information about the dri-devel
mailing list