[RFC 4/6] udmabuf: add a pointer to the miscdevice in dma-buf private data

Gerd Hoffmann kraxel at redhat.com
Thu Aug 1 06:42:48 UTC 2019


On Wed, Jul 31, 2019 at 07:25:15PM -0700, Gurchetan Singh wrote:
> Will be used later.
> 
> Signed-off-by: Gurchetan Singh <gurchetansingh at chromium.org>
> ---
>  drivers/dma-buf/udmabuf.c | 9 ++++++---
>  1 file changed, 6 insertions(+), 3 deletions(-)
> 
> diff --git a/drivers/dma-buf/udmabuf.c b/drivers/dma-buf/udmabuf.c
> index 134e53d24c2b..47003abbf4c2 100644
> --- a/drivers/dma-buf/udmabuf.c
> +++ b/drivers/dma-buf/udmabuf.c
> @@ -19,6 +19,7 @@ struct udmabuf {
>  	u32 flags;
>  	pgoff_t pagecount;
>  	struct page **pages;
> +	struct miscdevice *udmabuf_misc;

I'd name this "dev" or "device".

cheers,
  Gerd



More information about the dri-devel mailing list