[GIT PULL] Please pull hmm changes
Jerome Glisse
jglisse at redhat.com
Thu Dec 5 16:03:24 UTC 2019
On Tue, Dec 03, 2019 at 02:42:12AM +0000, Jason Gunthorpe wrote:
> On Sat, Nov 30, 2019 at 10:23:31AM -0800, Linus Torvalds wrote:
> > On Sat, Nov 30, 2019 at 10:03 AM Linus Torvalds
> > <torvalds at linux-foundation.org> wrote:
> > >
> > > I'll try to figure the code out, but my initial reaction was "yeah,
> > > not in my VM".
> >
> > Why is it ok to sometimes do
> >
> > WRITE_ONCE(mni->invalidate_seq, cur_seq);
> >
> > (to pair with the unlocked READ_ONCE), and sometimes then do
> >
> > mni->invalidate_seq = mmn_mm->invalidate_seq;
> >
> > My initial guess was that latter is only done at initialization time,
> > but at least in one case it's done *after* the mni has been added to
> > the mmn_mm (oh, how I despise those names - I can only repeat: WTF?).
>
> Yes, the only occurrences are in the notifier_insert, under the
> spinlock. The one case where it is out of the natural order was to
> make the manipulation of seq a bit saner, but in all cases since the
> spinlock is held there is no way for another thread to get the pointer
> to the 'mmu_interval_notifier *' to do the unlocked read.
>
> Regarding the ugly names.. Naming has been really hard here because
> currently everything is a 'mmu notifier' and the natural abberviations
> from there are crummy. Here is the basic summary:
>
> struct mmu_notifier_mm (ie the mm->mmu_notifier_mm)
> -> mmn_mm
> struct mm_struct
> -> mm
> struct mmu_notifier (ie the user subscription to the mm_struct)
> -> mn
> struct mmu_interval_notifier (the other kind of user subscription)
> -> mni
What about "interval" the context should already tell people
it is related to mmu notifier and thus a notifier. I would
just remove the notifier suffix, this would match the below
range.
> struct mmu_notifier_range (ie the args to invalidate_range)
> -> range
Yeah range as context should tell you it is related to mmu
notifier.
>
> I can send a patch to switch mmn_mm to mmu_notifier_mm, which is the
> only pre-existing name for this value. But IIRC, it is a somewhat ugly
> with long line wrapping. 'mni' is a pain, I have to reflect on that.
> (honesly, I dislike mmu_notififer_mm quite a lot too)
>
> I think it would be overall nicer with better names for the original
> structs. Perhaps:
>
> mmn_* - MMU notifier prefix
> mmn_state <- struct mmu_notifier_mm
> mmn_subscription (mmn_sub) <- struct mmu_notifier
> mmn_range_subscription (mmn_range_sub) <- struct mmu_interval_notifier
> mmn_invalidate_desc <- struct mmu_notifier_range
This looks good.
>
> At least this is how I describe them in my mind.. This is a lot of
> churn, and spreads through many drivers. This is why I kept the names
> as-is and we ended up with the also quite bad 'mmu_interval_notifier'
>
> Maybe just switch mmu_notifier_mm for mmn_state and leave the drivers
> alone?
>
> Anyone on the CC list have advice?
Maybe we can do a semantic patch to do convertion and then Linus
can easily apply the patch by just re-running the coccinelle.
Cheers,
Jérôme
More information about the dri-devel
mailing list