[GIT PULL] Please pull hmm changes
John Hubbard
jhubbard at nvidia.com
Thu Dec 5 23:03:56 UTC 2019
On 12/2/19 6:42 PM, Jason Gunthorpe wrote:
...
> Regarding the ugly names.. Naming has been really hard here because
> currently everything is a 'mmu notifier' and the natural abberviations
> from there are crummy. Here is the basic summary:
>
> struct mmu_notifier_mm (ie the mm->mmu_notifier_mm)
> -> mmn_mm
> struct mm_struct
> -> mm
> struct mmu_notifier (ie the user subscription to the mm_struct)
> -> mn
> struct mmu_interval_notifier (the other kind of user subscription)
> -> mni
> struct mmu_notifier_range (ie the args to invalidate_range)
> -> range
>
> I can send a patch to switch mmn_mm to mmu_notifier_mm, which is the
> only pre-existing name for this value. But IIRC, it is a somewhat ugly
> with long line wrapping. 'mni' is a pain, I have to reflect on that.
> (honesly, I dislike mmu_notififer_mm quite a lot too)
>
> I think it would be overall nicer with better names for the original
> structs. Perhaps:
>
> mmn_* - MMU notifier prefix
> mmn_state <- struct mmu_notifier_mm
> mmn_subscription (mmn_sub) <- struct mmu_notifier
> mmn_range_subscription (mmn_range_sub) <- struct mmu_interval_notifier
> mmn_invalidate_desc <- struct mmu_notifier_range
>
> At least this is how I describe them in my mind.. This is a lot of
> churn, and spreads through many drivers. This is why I kept the names
> as-is and we ended up with the also quite bad 'mmu_interval_notifier'
>
> Maybe just switch mmu_notifier_mm for mmn_state and leave the drivers
> alone?
>
> Anyone on the CC list have advice?
>
> Jason
No advice, just a naming idea similar in spirit to Jerome's suggestion
(use a longer descriptive word, and don't try to capture the entire phrase):
use "notif" in place of the unloved "mmn". So partially, approximately like
this:
notif_* <- MMU notifier prefix
notif_state <- struct mmu_notifier_mm
notif_subscription (notif_sub) <- struct mmu_notifier
notif_invalidate_desc <- struct mmu_notifier_range*
notif_range_subscription (notif_range_sub) <- struct mmu_interval_notifier
thanks,
--
John Hubbard
NVIDIA
More information about the dri-devel
mailing list