[PATCH 4/5] drm/panfrost: Add support for GPU heap allocations

Alyssa Rosenzweig alyssa at rosenzweig.io
Mon Jul 22 14:15:36 UTC 2019


>  #define PANFROST_BO_NOEXEC	1
> +#define PANFROST_BO_HEAP	2

Bikeshedding, but I don't like this name. There are, I think, multiple
GPU-mapped buffers (at least in Panfrost -- I don't know how the blob
manages memory) that can be considered heaps of sorts. Some of those are
just regular old BOs.

What makes these special is that they're growable. Calling it "heap" is
okay inside the kernel, but for the UABI, I'd prefer an explicit
"PANFROST_BO_GROWABLE(_HEAP)" to make it obvious what's going on.


More information about the dri-devel mailing list