[PATCH v2 0/3] drm/panfrost: drm_gem_map_offset() helper

Steven Price steven.price at arm.com
Thu May 16 14:14:44 UTC 2019


Panfrost has a re-implementation of drm_gem_dumb_map_offset() with an
extra bug regarding the handling of imported buffers. However we don't
really want Panfrost calling _dumb functions because it's not a KMS
driver.

This series renames drm_gem_dumb_map_offset() to drop the '_dumb' and
introduces a shmem helper to wrap it. This means that the shmem
implementation can be kept in sync with the semantics the
drm_gem_shmem_mmap() callback provides.

v1: https://lore.kernel.org/lkml/20190513143244.16478-1-steven.price@arm.com/
Changes since v1:
 * Rename drm_gem_dumb_map_offset to drop _dumb
 * Add a shmem helper

Steven Price (3):
  drm/gem: Rename drm_gem_dumb_map_offset() to drm_gem_map_offset()
  drm: shmem: Add drm_gem_shmem_map_offset() wrapper
  drm/panfrost: Use drm_gem_shmem_map_offset()

 drivers/gpu/drm/drm_dumb_buffers.c      |  4 ++--
 drivers/gpu/drm/drm_gem.c               |  6 +++---
 drivers/gpu/drm/drm_gem_shmem_helper.c  | 20 ++++++++++++++++++++
 drivers/gpu/drm/exynos/exynos_drm_gem.c |  3 +--
 drivers/gpu/drm/panfrost/panfrost_drv.c | 16 ++--------------
 include/drm/drm_gem.h                   |  4 ++--
 include/drm/drm_gem_shmem_helper.h      |  2 ++
 7 files changed, 32 insertions(+), 23 deletions(-)

-- 
2.20.1



More information about the dri-devel mailing list