[PATCH 1/5] drm/vmwgfx: move the require_exist handling together
Thomas Hellstrom
thellstrom at vmware.com
Fri Nov 8 15:22:01 UTC 2019
Hi, Emil!
On 11/8/19 2:14 PM, Emil Velikov wrote:
> On Fri, 1 Nov 2019 at 13:05, Emil Velikov <emil.l.velikov at gmail.com> wrote:
>> From: Emil Velikov <emil.velikov at collabora.com>
>>
>> Move the render_client hunk for require_exist alongside the rest.
>> Keeping all the reasons why an existing object is needed, in a single
>> place makes it easier to follow.
>>
>> Cc: VMware Graphics <linux-graphics-maintainer at vmware.com>
>> Cc: Thomas Hellstrom <thellstrom at vmware.com>
>> Signed-off-by: Emil Velikov <emil.velikov at collabora.com>
>> ---
>> drivers/gpu/drm/vmwgfx/vmwgfx_surface.c | 9 +++++----
>> 1 file changed, 5 insertions(+), 4 deletions(-)
>>
>> diff --git a/drivers/gpu/drm/vmwgfx/vmwgfx_surface.c b/drivers/gpu/drm/vmwgfx/vmwgfx_surface.c
>> index 29d8794f0421..1f989f3605c8 100644
>> --- a/drivers/gpu/drm/vmwgfx/vmwgfx_surface.c
>> +++ b/drivers/gpu/drm/vmwgfx/vmwgfx_surface.c
>> @@ -909,16 +909,12 @@ vmw_surface_handle_reference(struct vmw_private *dev_priv,
>> uint32_t handle;
>> struct ttm_base_object *base;
>> int ret;
>> - bool require_exist = false;
>>
>> if (handle_type == DRM_VMW_HANDLE_PRIME) {
>> ret = ttm_prime_fd_to_handle(tfile, u_handle, &handle);
>> if (unlikely(ret != 0))
>> return ret;
>> } else {
>> - if (unlikely(drm_is_render_client(file_priv)))
>> - require_exist = true;
>> -
>> handle = u_handle;
>> }
>>
>> @@ -935,6 +931,8 @@ vmw_surface_handle_reference(struct vmw_private *dev_priv,
>> }
>>
>> if (handle_type != DRM_VMW_HANDLE_PRIME) {
>> + bool require_exist = false;
>> +
>> user_srf = container_of(base, struct vmw_user_surface,
>> prime.base);
>>
>> @@ -946,6 +944,9 @@ vmw_surface_handle_reference(struct vmw_private *dev_priv,
>> user_srf->master != file_priv->master)
>> require_exist = true;
>>
>> + if (unlikely(drm_is_render_client(file_priv)))
>> + require_exist = true;
>> +
>> ret = ttm_ref_object_add(tfile, base, TTM_REF_USAGE, NULL,
>> require_exist);
>> if (unlikely(ret != 0)) {
>> --
> Thomas, VMware devs, humble poke?
> Any comments and review would be appreciated.
>
> Thanks
> Emil
>
Sorry, I'll look at this early monday.
Thanks,
Thomas
More information about the dri-devel
mailing list