[Bug 111989] Diagnosing issues with Radeon VII

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Tue Oct 15 00:42:03 UTC 2019


--- Comment #1 from L.S.S. <ragnaros39216 at yandex.com> ---
A little update:

Was able to trigger system lockup/hard reset even at low clock speed (at around
1000MHz) last night. It happened when I reapplied the clock settings after it
entered safe clock again, most likely due to that I was also doing something
else on the system (which caused the card to enter safe clock in the first

I still couldn't find a way to increase the log verbosity, but I've tried the

1. Disabling CUs to match that of a Vega 56
(amdgpu.disable_cu=0.0.14,0.0.15,1.0.14,1.0.15,2.0. 14,2.0.15,3.0.14,3.0.15,
found in the Phoronix post[1]). This obviously had no effect as I'm yet to know
which are the real ones I should disable, or if this problem can really be
worked around or not this way.

2. Disabling DC (amdgpu.dc=0): The system won't boot at all.

3. Setting amdgpu.vm_update_mode=3: The system freezes a short while after
startup, but it doesn't hard reset. I can just press the reset button and the
card still works after reboot, without having to do a power cycle.

The system is currently at the latest stable kernel (5.3), but the problem had
existed for quite a while (on all kernel versions, so it must be due to the
hardware itself).

NOTE: On the other hand, the card seems to intermittently cause stutters to the
system possibly with some related but corrected AERs showing in the system log,
but the problem went away after I set the PCIe slot the card is on to GEN2


You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.freedesktop.org/archives/dri-devel/attachments/20191015/60fd393c/attachment.html>

More information about the dri-devel mailing list