[PATCH 05/15] drm/dp: Add drm_dp_alternate_scrambler_reset_cap() helper

Thierry Reding thierry.reding at gmail.com
Tue Oct 15 14:34:59 UTC 2019


From: Thierry Reding <treding at nvidia.com>

Add a helper to check if the sink supports the eDP alternate scrambler
reset value of 0xfffe.

Signed-off-by: Thierry Reding <treding at nvidia.com>
---
 include/drm/drm_dp_helper.h | 7 +++++++
 1 file changed, 7 insertions(+)

diff --git a/include/drm/drm_dp_helper.h b/include/drm/drm_dp_helper.h
index 7ff7bf0e742d..7a537ffc2fb1 100644
--- a/include/drm/drm_dp_helper.h
+++ b/include/drm/drm_dp_helper.h
@@ -1290,6 +1290,13 @@ drm_dp_channel_coding_supported(const u8 dpcd[DP_RECEIVER_CAP_SIZE])
 	return dpcd[DP_MAIN_LINK_CHANNEL_CODING] & DP_CAP_ANSI_8B10B;
 }
 
+static inline bool
+drm_dp_alternate_scrambler_reset_cap(const u8 dpcd[DP_RECEIVER_CAP_SIZE])
+{
+	return dpcd[DP_EDP_CONFIGURATION_CAP] &
+			DP_ALTERNATE_SCRAMBLER_RESET_CAP;
+}
+
 /*
  * DisplayPort AUX channel
  */
-- 
2.23.0



More information about the dri-devel mailing list