[PATCH RESEND 0/8] drm/print: cleanup and new drm_device based logging

Jani Nikula jani.nikula at intel.com
Mon Oct 28 10:38:14 UTC 2019


Resend of [1]; I may have rebased but I'm not sure anymore...

For starters some fairly benign cleanup, and a proposal for new struct
drm_device based drm logging macros analoguous to core kernel struct
device based macros.

Please let's at least get the first 7 reviewed/acked/merged, shall we?


BR,
Jani.


[1] https://patchwork.freedesktop.org/series/67795/


Jani Nikula (8):
  drm/i915: use drm_debug_enabled() to check for debug categories
  drm/nouveau: use drm_debug_enabled() to check for debug categories
  drm/amdgpu: use drm_debug_enabled() to check for debug categories
  drm/print: rename drm_debug to __drm_debug to discourage use
  drm/print: underscore prefix functions that should be private to print
  drm/print: convert debug category macros into an enum
  drm/print: group logging functions by prink or device based
  drm/print: introduce new struct drm_device based logging macros

 drivers/gpu/drm/amd/amdgpu/smu_v11_0_i2c.c   |   4 +-
 drivers/gpu/drm/drm_print.c                  |  18 +-
 drivers/gpu/drm/i915/display/intel_display.c |   4 +-
 drivers/gpu/drm/i915/display/intel_dp.c      |   2 +-
 drivers/gpu/drm/i915/i915_drv.c              |   2 +-
 drivers/gpu/drm/i915/i915_gem.h              |   2 +-
 drivers/gpu/drm/i915/i915_utils.c            |   2 +-
 drivers/gpu/drm/i915/intel_pm.c              |   2 +-
 drivers/gpu/drm/nouveau/dispnv50/disp.h      |   4 +-
 drivers/gpu/drm/nouveau/nouveau_drv.h        |   4 +-
 include/drm/drm_print.h                      | 304 ++++++++++++-------
 11 files changed, 224 insertions(+), 124 deletions(-)

-- 
2.20.1



More information about the dri-devel mailing list