[Bug 204725] black screen

bugzilla-daemon at bugzilla.kernel.org bugzilla-daemon at bugzilla.kernel.org
Sun Sep 1 08:53:35 UTC 2019


--- Comment #35 from Dmitri Seletski (drjoms at gmail.com) ---
we got some progress. Or may be not. Since I suspect original issue is still
not solved. Still get black screen when amdgpu is loaded. This time, however, I
can start Xorg, with no 3d or 2d acceleration, but not using VESA driver, but
using AMDGPU.

My guess is, we fixed second problem, I did not know existed. Which is good all
the same.
Because I had several versions of LLVM, older one was used by default and only
newer was showing up as installed by portage(gentoo packaging system). It shows
only last installed. Shame on me, I hsould have known better. To my defence,
there are very a few packages where you have several versions of same package
installed and they usually can be chosed using 'eselect' command.

eselect |grep llvm

this is now me sitting under:
uname -a
Linux (none)dimko's Desktop 5.3.0-rc6+ #8 SMP PREEMPT Sun Sep 1 07:39:44 IST
2019 x86_64 AMD Ryzen 5 1600 Six-Core Processor AuthenticAMD GNU/Linux

name of display: :0.0
Error: couldn't find RGB GLX visual or fbconfig

Error: couldn't get an RGB, Double-buffered visual

see new dmesg(nothing interesting there)
and new Xorg.log files in next message.(a lot of interesting there)

You are receiving this mail because:
You are watching the assignee of the bug.

More information about the dri-devel mailing list