[PATCH v4 0/4] Add a generic driver for LED-based backlight

Daniel Thompson daniel.thompson at linaro.org
Mon Sep 9 11:12:13 UTC 2019


On Sun, Sep 08, 2019 at 06:17:50PM +0200, Jacek Anaszewski wrote:
> On 7/22/19 11:23 PM, Jacek Anaszewski wrote:
> > On 7/22/19 9:06 AM, Lee Jones wrote:
> >> On Thu, 18 Jul 2019, Jacek Anaszewski wrote:
> >>
> >>> On 7/17/19 4:15 PM, Jean-Jacques Hiblot wrote:
> >>>> This series aims to add a led-backlight driver, similar to pwm-backlight,
> >>>> but using a LED class device underneath.
> >>>>
> >>>> A few years ago (2015), Tomi Valkeinen posted a series implementing a
> >>>> backlight driver on top of a LED device:
> >>>> https://patchwork.kernel.org/patch/7293991/
> >>>> https://patchwork.kernel.org/patch/7294001/
> >>>> https://patchwork.kernel.org/patch/7293981/
> >>>>
> >>>> The discussion stopped because Tomi lacked the time to work on it.
> >>>>
> >>>> changes in v4:
> >>>> - fix dev_err() messages and commit logs following the advices of Pavel
> >>>> - cosmetic changes (indents, getting rid of  "? 1 : 0" in
> >>>>   led_match_led_node())
> >>>>
> >>>> changes in v3:
> >>>> - dt binding: don't limit the brightness range to 0-255. Use the range of
> >>>>   the underlying LEDs. as a side-effect, all LEDs must now have the same
> >>>>   range
> >>>> - driver: Adapt to dt binding update.
> >>>> - driver: rework probe() for clarity and remove the remaining goto.
> >>>>
> >>>> changes in v2:
> >>>> - handle more than one LED.
> >>>> - don't make the backlight device a child of the LED controller.
> >>>> - make brightness-levels and default-brightness-level optional
> >>>> - removed the option to use a GPIO enable.
> >>>> - removed the option to use a regulator. It should be handled by the LED
> >>>>   core
> >>>> - don't make any change to the LED core (not needed anymore)
> >>>>
> >>>> Jean-Jacques Hiblot (2):
> >>>>   leds: Add managed API to get a LED from a device driver
> >>>>   dt-bindings: backlight: Add led-backlight binding
> >>>>
> >>>> Tomi Valkeinen (2):
> >>>>   leds: Add of_led_get() and led_put()
> >>>>   backlight: add led-backlight driver
> >>>>
> >>>>  .../bindings/leds/backlight/led-backlight.txt |  28 ++
> >>>>  drivers/leds/led-class.c                      |  92 ++++++
> >>>>  drivers/video/backlight/Kconfig               |   7 +
> >>>>  drivers/video/backlight/Makefile              |   1 +
> >>>>  drivers/video/backlight/led_bl.c              | 268 ++++++++++++++++++
> >>>>  include/linux/leds.h                          |   6 +
> >>>>  6 files changed, 402 insertions(+)
> >>>>  create mode 100644 Documentation/devicetree/bindings/leds/backlight/led-backlight.txt
> >>>>  create mode 100644 drivers/video/backlight/led_bl.c
> >>>>
> >>>
> >>> For the whole set:
> >>>
> >>> Acked-by: Jacek Anaszewski <jacek.anaszewski at gmail.com>
> >>>
> >>> Lee - we need to create immutable branch for this set since there will
> >>> be some interfering changes in the LED core in this cycle.
> >>>
> >>> I can create the branch and send the pull request once we will
> >>> obtain the ack from Rob for DT bindings, unless you have other
> >>> preference.
> >>
> >> We also require a review to be conducted by Daniel Thompson.
> >>
> >> After which, an immutable branch sounds like a good idea.  I'd like to
> >> create this myself if you don't mind.
> > 
> > Sure, thanks.
> 
> Unfortunately that hasn't happened and it will miss 5.4 merge window.
> 
> Daniel, we need your ack for this patch set.

Sorry for dropping the ball here.

I'm afraid I couldn't ack since I spotted a bug but I have shared
review feedback now!


Daniel.


More information about the dri-devel mailing list