[PATCH V2] amdgpu: remove unnecessary condition check

Felix Kuehling felix.kuehling at amd.com
Tue Apr 21 04:24:19 UTC 2020


Hi Bernard,

Please see comments inline.

Am 2020-04-20 um 10:41 p.m. schrieb Bernard Zhao:
> There is no need to if check again, maybe we could merge
> into the above else branch.
>
> Signed-off-by: Bernard Zhao <bernard at vivo.com>
>
> ---
> Changes since V1:
> *commit message improve
> *code style refactoring
>
> Link for V1:
> * https://lore.kernel.org/patchwork/patch/1226587/
> ---
>  drivers/gpu/drm/amd/amdgpu/amdgpu_amdkfd_gpuvm.c | 16 +++++++++-------
>  1 file changed, 9 insertions(+), 7 deletions(-)
>
> diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_amdkfd_gpuvm.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_amdkfd_gpuvm.c
> index 9dff792c9290..a64eeb07bec4 100644
> --- a/drivers/gpu/drm/amd/amdgpu/amdgpu_amdkfd_gpuvm.c
> +++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_amdkfd_gpuvm.c
> @@ -660,13 +660,15 @@ static int reserve_bo_and_vm(struct kgd_mem *mem,
>  
>  	ret = ttm_eu_reserve_buffers(&ctx->ticket, &ctx->list,
>  				     false, &ctx->duplicates);
> -	if (!ret)
> -		ctx->reserved = true;
> -	else {
> +
> +	if (ret) {
>  		pr_err("Failed to reserve buffers in ttm\n");
>  		kfree(ctx->vm_pd);
>  		ctx->vm_pd = NULL;
>  	}
> +	else {
> +		ctx->reserved = true;
> +	}

Here you're just reversing the if and else branches. This change looks
completely superfluous to me.

You're also breaking coding style conventions. The "else" should be on
the same line as the closing brace "}". I'm pretty sure checkpatch.pl
will complain about this.


>  
>  	return ret;
>  }
> @@ -733,15 +735,15 @@ static int reserve_bo_and_cond_vms(struct kgd_mem *mem,
>  
>  	ret = ttm_eu_reserve_buffers(&ctx->ticket, &ctx->list,
>  				     false, &ctx->duplicates);
> -	if (!ret)
> -		ctx->reserved = true;
> -	else
> -		pr_err("Failed to reserve buffers in ttm.\n");
>  
>  	if (ret) {
> +		pr_err("Failed to reserve buffers in ttm.\n");
>  		kfree(ctx->vm_pd);
>  		ctx->vm_pd = NULL;
>  	}
> +	else {
> +		ctx->reserved = true;
> +	}

Same as above regarding coding style.

To minimize unnecessary code changes, you can merge the "if (ret) ..."
code into the else-branch of the previous if.

Regards,
  Felix


>  
>  	return ret;
>  }


More information about the dri-devel mailing list