[PATCH v5 00/29] Convert DSI code to use drm_mipi_dsi and drm_panel (second half)
Tomi Valkeinen
tomi.valkeinen at ti.com
Tue Dec 8 12:28:26 UTC 2020
Hi,
This is version 5 of the series OMAP DSI conversion series. Previous
version can be found from:
https://www.spinics.net/lists/linux-omap/msg157480.html
To lessen the patch spam, I'm sending only patches starting from patch
56/80. There has been no changes to the patches before 56/80.
Diff between v4 and v5 is not much. There are no functional changes at
the end of the series (diff between v4 and v5 shows only cosmetic
changes, except fixing one missing r = 0 initialization).
The biggest change is splitting "drm/omap: dsi: cleanup channel usages"
into three parts. Also, the last patch is new in this version, although
I did send it for v4 as 81/80.
Other changes include minor clarifications and cleanups in the
descriptions, and moving a few changes from one commit to another in
case the change logically belongs to the other commit.
Tomi
Tomi Valkeinen (29):
drm/panel: panel-dsi-cm: cleanup tear enable
ARM: dts: omap5: add address-cells & size-cells to dsi
drm/omap: pll: fix iteration loop check
drm/omap: dsi: set trans_mode according to client mode_flags
drm/panel: panel-dsi-cm: set column & page at setup
drm/omap: dsi: send nop instead of page & column
drm/omap: dsi: simplify VC handling
drm/omap: dsi: drop useless channel checks
drm/omap: dsi: cleanup dispc channel usage
drm/omap: dsi: rename 'channel' to 'vc'
drm/omap: dsi: pass vc to various functions
drm/omap: dsi: untangle vc & channel
drm/omap: dsi: skip dsi_vc_enable_hs when already in correct mode
drm/omap: dsi: enable HS before sending the frame
drm/omap: dsi: use separate VCs for cmd and video
drm/panel: panel-dsi-cm: remove extra 'if'
drm/panel: panel-dsi-cm: add panel database to driver
drm/panel: panel-dsi-cm: drop unneeded includes
drm/omap: dsi: move structs & defines to dsi.h
drm/omap: dsi: move enable/disable to bridge enable/disable
drm/omap: dsi: display_enable cleanup
drm/omap: dsi: display_disable cleanup
drm/omap: dsi: rename dsi_display_* functions
drm/omap: dsi: cleanup initial vc setup
drm/omap: dsi: split video mode enable/disable into separate func
drm/omap: dsi: fix and cleanup ddr_clk_always_on
drm/omap: dsi: remove ulps support
drm/omap: dsi: fix DCS_CMD_ENABLE
drm/omap: dsi: allow DSI commands to be sent early
arch/arm/boot/dts/omap5.dtsi | 6 +
drivers/gpu/drm/omapdrm/dss/dsi.c | 1375 ++++++-------------------
drivers/gpu/drm/omapdrm/dss/dsi.h | 456 ++++++++
drivers/gpu/drm/omapdrm/dss/omapdss.h | 64 --
drivers/gpu/drm/omapdrm/dss/pll.c | 6 +
drivers/gpu/drm/panel/panel-dsi-cm.c | 161 +--
6 files changed, 899 insertions(+), 1169 deletions(-)
create mode 100644 drivers/gpu/drm/omapdrm/dss/dsi.h
--
Texas Instruments Finland Oy, Porkkalankatu 22, 00180 Helsinki.
Y-tunnus/Business ID: 0615521-4. Kotipaikka/Domicile: Helsinki
More information about the dri-devel
mailing list