[PATCH 34/49] drm/ttm: make manager debug function optional

Christian König christian.koenig at amd.com
Fri Jul 31 13:03:20 UTC 2020


Am 31.07.20 um 11:46 schrieb daniel at ffwll.ch:
> On Fri, Jul 31, 2020 at 02:05:05PM +1000, Dave Airlie wrote:
>> From: Dave Airlie <airlied at redhat.com>
>>
>> Signed-off-by: Dave Airlie <airlied at redhat.com>
>> ---
>>   drivers/gpu/drm/ttm/ttm_bo.c | 2 +-
>>   1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/drivers/gpu/drm/ttm/ttm_bo.c b/drivers/gpu/drm/ttm/ttm_bo.c
>> index 92de8a6d7647..1e8fda1c9b3a 100644
>> --- a/drivers/gpu/drm/ttm/ttm_bo.c
>> +++ b/drivers/gpu/drm/ttm/ttm_bo.c
>> @@ -88,7 +88,7 @@ static void ttm_mem_type_debug(struct ttm_bo_device *bdev, struct drm_printer *p
>>   	drm_printf(p, "    size: %llu\n", man->size);
>>   	drm_printf(p, "    available_caching: 0x%08X\n", man->available_caching);
>>   	drm_printf(p, "    default_caching: 0x%08X\n", man->default_caching);
>> -	if (mem_type != TTM_PL_SYSTEM)
>> +	if (mem_type != TTM_PL_SYSTEM && man->func->debug)
>>   		(*man->func->debug)(man, p);
>>   }
> Bit a bikeshed, but what about exporting this function (maybe with the man
> as argument, not the bdev, mem_type pair) and using it in the first 2
> patches? Avoids surprises with optional func->debug.

+1 for that. That's no bikeshed at all but just clean design.

And we should rename all those backend related functions and move them 
into a separate [ch] file.

E.g. let's just have a backend resource object TTM works with.

Christian.

> -Daniel
>
>>   
>> -- 
>> 2.26.2
>>
>> _______________________________________________
>> dri-devel mailing list
>> dri-devel at lists.freedesktop.org
>> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Flists.freedesktop.org%2Fmailman%2Flistinfo%2Fdri-devel&data=02%7C01%7Cchristian.koenig%40amd.com%7C8540e6d1e99547722b2c08d83536929d%7C3dd8961fe4884e608e11a82d994e183d%7C0%7C0%7C637317855794189396&sdata=GpkfEetygk53dJ1qWiF%2FucNVRc9%2FxWLzKc2BGuG9bLg%3D&reserved=0



More information about the dri-devel mailing list