[Intel-gfx] [PATCH v4 1/2] drm/edid: Name the detailed monitor range flags

Jani Nikula jani.nikula at linux.intel.com
Fri Mar 6 10:30:46 UTC 2020


On Thu, 05 Mar 2020, Manasi Navare <manasi.d.navare at intel.com> wrote:
> This patch adds defines for the detailed monitor
> range flags as per the EDID specification.
>
> Suggested-by: Ville Syrjälä <ville.syrjala at linux.intel.com>
> Cc: Ville Syrjälä <ville.syrjala at linux.intel.com>
> Cc: Harry Wentland <harry.wentland at amd.com>
> Cc: Clinton A Taylor <clinton.a.taylor at intel.com>
> Cc: Kazlauskas Nicholas <Nicholas.Kazlauskas at amd.com>
> Signed-off-by: Manasi Navare <manasi.d.navare at intel.com>
> ---
>  include/drm/drm_edid.h | 5 +++++
>  1 file changed, 5 insertions(+)
>
> diff --git a/include/drm/drm_edid.h b/include/drm/drm_edid.h
> index f0b03d401c27..f89c97623845 100644
> --- a/include/drm/drm_edid.h
> +++ b/include/drm/drm_edid.h
> @@ -91,6 +91,11 @@ struct detailed_data_string {
>  	u8 str[13];
>  } __attribute__((packed));
>  
> +#define EDID_DEFAULT_GTF_SUPPORT_FLAG   0x00
> +#define EDID_RANGE_LIMITS_ONLY_FLAG     0x01
> +#define EDID_SECONDARY_GTF_SUPPORT_FLAG 0x02
> +#define EDID_CVT_SUPPORT_FLAG           0x04

Bikeshed for consideration:

drm_edid.h has some macros with DRM_EDID_ prefix, some with EDID_
prefix, and then some with no prefix at all really. Should we start
consolidating on something when we add more?

BR,
Jani.


> +
>  struct detailed_data_monitor_range {
>  	u8 min_vfreq;
>  	u8 max_vfreq;

-- 
Jani Nikula, Intel Open Source Graphics Center


More information about the dri-devel mailing list