[PATCH v7 06/15] PM / EM: change name of em_pd_energy to em_cpu_energy

Quentin Perret qperret at google.com
Mon May 11 13:45:55 UTC 2020

On Monday 11 May 2020 at 12:19:03 (+0100), Lukasz Luba wrote:
> Energy Model framework supports now other devices than CPUs. Refactor some
> of the functions in order to prevent wrong usage. The old function
> em_pd_energy has to generic name. It must not be used without proper
> cpumask pointer, which is possible only for CPU devices. Thus, rename it
> and add proper description to warn of potential wrong usage for other
> devices.
> Acked-by: Daniel Lezcano <daniel.lezcano at linaro.org>
> Signed-off-by: Lukasz Luba <lukasz.luba at arm.com>

Acked-by: Quentin Perret <qperret at google.com>

More information about the dri-devel mailing list