[PATCH v2 30/38] drm/rockchip: remove _unlocked suffix in drm_object_put_unlocked

Heiko Stübner heiko at sntech.de
Fri May 15 10:23:27 UTC 2020

Am Freitag, 15. Mai 2020, 11:51:10 CEST schrieb Emil Velikov:
> From: Emil Velikov <emil.velikov at collabora.com>
> Spelling out _unlocked for each and every driver is a annoying.
> Especially if we consider how many drivers, do not know (or need to)
> about the horror stories involving struct_mutex.
> Just drop the suffix. It makes the API cleaner.
> Done via the following script:
> __from=drm_gem_object_put_unlocked
> __to=drm_gem_object_put
> for __file in $(git grep --name-only $__from); do
>   sed -i  "s/$__from/$__to/g" $__file;
> done
> Cc: Sandy Huang <hjc at rock-chips.com>
> Cc: "Heiko Stübner" <heiko at sntech.de>
> Cc: David Airlie <airlied at linux.ie>
> Signed-off-by: Emil Velikov <emil.velikov at collabora.com>
> Acked-by: Sam Ravnborg <sam at ravnborg.org>

Acked-by: Heiko Stuebner <heiko at sntech.de>

More information about the dri-devel mailing list