[PATCH v2 12/38] drm/gem: add drm_object_put helper

Steven Price steven.price at arm.com
Fri May 15 15:14:59 UTC 2020


On 15/05/2020 10:50, Emil Velikov wrote:
> From: Emil Velikov <emil.velikov at collabora.com>
> 
> Spelling out _unlocked for each and every driver is a annoying.
> Especially if we consider how many drivers, do not know (or need to)
> about the horror stories involving struct_mutex.
> 
> Add helper, which will allow us to transition the drivers one by one,
> dropping the suffix.
> 
> v2: add missing space after function name (Jani)
> 
> Signed-off-by: Emil Velikov <emil.velikov at collabora.com>
> Acked-by: Sam Ravnborg <sam at ravnborg.org> (v1)

NIT: The subject is wrong: s/drm_object_put/drm_gem_object_put/

With that fixed:

Reviewed-by: Steven Price <steven.price at arm.com>

Steve

> ---
>   include/drm/drm_gem.h | 6 ++++--
>   1 file changed, 4 insertions(+), 2 deletions(-)
> 
> diff --git a/include/drm/drm_gem.h b/include/drm/drm_gem.h
> index a231a2b3f5ac..2f7b86c0649c 100644
> --- a/include/drm/drm_gem.h
> +++ b/include/drm/drm_gem.h
> @@ -364,17 +364,19 @@ static inline void drm_gem_object_get(struct drm_gem_object *obj)
>   }
>   
>   /**
> - * drm_gem_object_put_unlocked - drop a GEM buffer object reference
> + * drm_gem_object_put - drop a GEM buffer object reference
>    * @obj: GEM buffer object
>    *
>    * This releases a reference to @obj.
>    */
>   static inline void
> -drm_gem_object_put_unlocked(struct drm_gem_object *obj)
> +drm_gem_object_put(struct drm_gem_object *obj)
>   {
>   	kref_put(&obj->refcount, drm_gem_object_free);
>   }
>   
> +#define drm_gem_object_put_unlocked drm_gem_object_put
> +
>   void drm_gem_object_put_locked(struct drm_gem_object *obj);
>   
>   int drm_gem_handle_create(struct drm_file *file_priv,
> 



More information about the dri-devel mailing list