[PATCH v3 3/7] drm/vc4: kms: Rename NUM_CHANNELS

Thomas Zimmermann tzimmermann at suse.de
Thu Nov 19 07:56:48 UTC 2020



Am 05.11.20 um 14:56 schrieb Maxime Ripard:
> The NUM_CHANNELS define has a pretty generic name and was right before the
> function using it. Let's move to something that makes the hardware-specific
> nature more obvious, and to a more appropriate place.
> 
> Reviewed-by: Hoegeun Kwon <hoegeun.kwon at samsung.com>
> Tested-by: Hoegeun Kwon <hoegeun.kwon at samsung.com>
> Signed-off-by: Maxime Ripard <maxime at cerno.tech>

Reviewed-by: Thomas Zimmermann <tzimmermann at suse.de>

> ---
>   drivers/gpu/drm/vc4/vc4_kms.c | 6 +++---
>   1 file changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/drivers/gpu/drm/vc4/vc4_kms.c b/drivers/gpu/drm/vc4/vc4_kms.c
> index 4b558ccb18fe..ad69c70f66a2 100644
> --- a/drivers/gpu/drm/vc4/vc4_kms.c
> +++ b/drivers/gpu/drm/vc4/vc4_kms.c
> @@ -24,6 +24,8 @@
>   #include "vc4_drv.h"
>   #include "vc4_regs.h"
>   
> +#define HVS_NUM_CHANNELS 3
> +
>   struct vc4_ctm_state {
>   	struct drm_private_state base;
>   	struct drm_color_ctm *ctm;
> @@ -660,12 +662,10 @@ static int vc4_load_tracker_obj_init(struct vc4_dev *vc4)
>   	return drmm_add_action_or_reset(&vc4->base, vc4_load_tracker_obj_fini, NULL);
>   }
>   
> -#define NUM_CHANNELS 3
> -
>   static int
>   vc4_atomic_check(struct drm_device *dev, struct drm_atomic_state *state)
>   {
> -	unsigned long unassigned_channels = GENMASK(NUM_CHANNELS - 1, 0);
> +	unsigned long unassigned_channels = GENMASK(HVS_NUM_CHANNELS - 1, 0);
>   	struct drm_crtc_state *old_crtc_state, *new_crtc_state;
>   	struct drm_crtc *crtc;
>   	int i, ret;
> 

-- 
Thomas Zimmermann
Graphics Driver Developer
SUSE Software Solutions Germany GmbH
Maxfeldstr. 5, 90409 Nürnberg, Germany
(HRB 36809, AG Nürnberg)
Geschäftsführer: Felix Imendörffer
-------------- next part --------------
A non-text attachment was scrubbed...
Name: OpenPGP_0x680DC11D530B7A23.asc
Type: application/pgp-keys
Size: 7435 bytes
Desc: not available
URL: <https://lists.freedesktop.org/archives/dri-devel/attachments/20201119/58edf7d3/attachment.key>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: OpenPGP_signature
Type: application/pgp-signature
Size: 840 bytes
Desc: OpenPGP digital signature
URL: <https://lists.freedesktop.org/archives/dri-devel/attachments/20201119/58edf7d3/attachment.sig>


More information about the dri-devel mailing list