[PATCH v4 60/80] drm/panel: panel-dsi-cm: set column & page at setup
Tomi Valkeinen
tomi.valkeinen at ti.com
Tue Nov 24 18:19:45 UTC 2020
On 24/11/2020 19:30, Sam Ravnborg wrote:
> On Tue, Nov 24, 2020 at 02:45:18PM +0200, Tomi Valkeinen wrote:
>> Set the column & page address once during setup, instead of relying the
>> DSI host driver to set those.
>>
>> Signed-off-by: Tomi Valkeinen <tomi.valkeinen at ti.com>
> Reviewed-by: Sam Ravnborg <sam at ravnborg.org>
>
> But one comment below.
>
>> ---
>> drivers/gpu/drm/panel/panel-dsi-cm.c | 24 ++++++++++++++++++++++++
>> 1 file changed, 24 insertions(+)
>>
>> diff --git a/drivers/gpu/drm/panel/panel-dsi-cm.c b/drivers/gpu/drm/panel/panel-dsi-cm.c
>> index 59e8e6b18e97..1e7f73340736 100644
>> --- a/drivers/gpu/drm/panel/panel-dsi-cm.c
>> +++ b/drivers/gpu/drm/panel/panel-dsi-cm.c
>> @@ -171,6 +171,26 @@ static int dsicm_get_id(struct panel_drv_data *ddata, u8 *id1, u8 *id2, u8 *id3)
>> return 0;
>> }
>>
>> +static int dsicm_set_update_window(struct panel_drv_data *ddata)
>> +{
>> + struct mipi_dsi_device *dsi = ddata->dsi;
>> + int r;
>> + u16 x1 = 0;
>> + u16 x2 = ddata->mode.hdisplay - 1;
>> + u16 y1 = 0;
>> + u16 y2 = ddata->mode.vdisplay - 1;
>
> It does not help the readability with the variables.
>
> Using
>
> r = mipi_dsi_dcs_set_column_address(dsi, 0, ddata->mode.hdisplay - 1);
>
> would IMO be easier to parse.
>
> Then the pointless assignment of x1 and y1 are dropped too.
I think I agree with you here, although the variables do make it clearer to the reader that the
parameters are x1 and x2, not x and w.
Tomi
--
Texas Instruments Finland Oy, Porkkalankatu 22, 00180 Helsinki.
Y-tunnus/Business ID: 0615521-4. Kotipaikka/Domicile: Helsinki
More information about the dri-devel
mailing list