[PATCH v3 19/20] drm/tegra: Implement new UAPI

Mikko Perttunen cyndis at kapsi.fi
Wed Oct 28 09:54:03 UTC 2020


On 10/27/20 9:06 PM, Dmitry Osipenko wrote:
> 26.10.2020 12:11, Mikko Perttunen пишет:
>>>
>>> The first patches should be the ones that are relevant to the existing
>>> userspace code, like support for the waits.
>>
>> Can you elaborate what you mean by this?
> 
> All features that don't have an immediate real use-case should be placed
> later in the series because we may defer merging of those patches until
> we will see userspace that uses those features since we can't really
> decide whether these are decisions that we won't regret later on, only
> practical application can confirm the correctness.

I was more referring to the "support for waits" part, should have 
clarified that.

> 
>>> Partial mappings should be a separate feature because it's a
>>> questionable feature that needs to be proved by a real userspace first.
>>> Maybe it would be even better to drop it for the starter, to ease
>>> reviewing.
>>
>> Considering that the "no-op" support for it (map the whole buffer but
>> just keep track of the starting offset) is only a couple of lines, I'd
>> like to keep it in.
> 
> There is no tracking in the current code which prevents the duplicated
> mappings, will we need to care about it? This a bit too questionable
> feature for now, IMO. I'd like to see it as a separate patch.

I don't think there is any need to special case duplicated mappings. I 
think this is a pretty obvious feature to have, but I can rename them to 
reserved0 and reserved1 and require that reserved0 is zero and reserved1 
is the size of the passed GEM object.

> 
> ...
>>> I'd like to see the DRM_SCHED and syncobj support. I can help you with
>>> it if it's out of yours scope for now.
>>>
>>
>> I already wrote some code for syncobj I can probably pull in. Regarding
>> DRM_SCHED, help is accepted. However, we should keep using the hardware
>> scheduler, and considering it's a bigger piece of work, let's not block
>> this series on it.
> 
> I'd like to see all the custom IOCTLs to be deprecated and replaced with
> the generic DRM API wherever possible. Hence, I think it should be a
> mandatory features that we need to focus on. The current WIP userspace
> already uses and relies on DRM_SCHED.
> 

 From my point of view, the ABI needs to be designed such that it can 
replace what we have downstream, i.e. it needs to support the usecases 
the downstream nvhost ABI supports currently. Otherwise there is no 
migration path to upstream and it's not worth it for me to work on this.

Although, I don't see what this ABI is missing that your userspace would 
rely on. Does it submit jobs in reverse order that would deadlock if 
drm_sched didn't reorder them based on prefences, or something?

Software-based scheduling might make sense in situations where the 
channel is shared by all processes, but at least for modern chips that 
are designed to use hardware scheduling, I want to use that capability.

Mikko


More information about the dri-devel mailing list