[PULL] topic/nouveau-i915-dp-helpers-and-cleanup
Rodrigo Vivi
rodrigo.vivi at intel.com
Fri Sep 4 13:24:34 UTC 2020
On Mon, Aug 31, 2020 at 07:38:57PM -0400, Lyude Paul wrote:
> topic/nouveau-i915-dp-helpers-and-cleanup-2020-08-31-1:
> UAPI Changes:
>
> None
>
> Cross-subsystem Changes:
>
> * Moves a bunch of miscellaneous DP code from the i915 driver into a set
> of shared DRM DP helpers
>
> Core Changes:
>
> * New DRM DP helpers (see above)
>
> Driver Changes:
>
> * Implements usage of the aforementioned DP helpers in the nouveau
> driver, along with some other various HPD related cleanup for nouveau
was this picked-up on the nouveau side already?
whenever that happens, please ping me so I can pull this to dinq.
But a reminder that it has my ack to go to drm-misc or only to nouveau
directly.
> The following changes since commit bfacb84993eb173c0ab53ca4dd6180f76f4dc176:
>
> drm: virtio: fix kconfig dependency warning (2020-08-31 08:55:02 +0200)
>
> are available in the Git repository at:
>
> git://anongit.freedesktop.org/drm/drm-misc tags/topic/nouveau-i915-dp-helpers-and-cleanup-2020-08-31-1
>
> for you to fetch changes up to 79416e97dda0118b137302575a70a14259a27d7d:
>
> drm/nouveau/kms: Start using drm_dp_read_dpcd_caps() (2020-08-31 19:10:09 -0400)
>
> ----------------------------------------------------------------
> UAPI Changes:
>
> None
>
> Cross-subsystem Changes:
>
> * Moves a bunch of miscellaneous DP code from the i915 driver into a set
> of shared DRM DP helpers
>
> Core Changes:
>
> * New DRM DP helpers (see above)
>
> Driver Changes:
>
> * Implements usage of the aforementioned DP helpers in the nouveau
> driver, along with some other various HPD related cleanup for nouveau
>
> ----------------------------------------------------------------
> Lyude Paul (20):
> drm/nouveau/kms: Fix some indenting in nouveau_dp_detect()
> drm/nouveau/kms/nv50-: Remove open-coded drm_dp_read_desc()
> drm/nouveau/kms/nv50-: Just use drm_dp_dpcd_read() in nouveau_dp.c
> drm/nouveau/kms/nv50-: Use macros for DP registers in nouveau_dp.c
> drm/nouveau/kms: Don't clear DP_MST_CTRL DPCD in nv50_mstm_new()
> drm/nouveau/kms: Search for encoders' connectors properly
> drm/nouveau/kms/nv50-: Use drm_dp_dpcd_(readb|writeb)() in nv50_sor_disable()
> drm/nouveau/kms/nv50-: Refactor and cleanup DP HPD handling
> drm/i915/dp: Extract drm_dp_read_mst_cap()
> drm/nouveau/kms: Use new drm_dp_read_mst_cap() helper for checking MST caps
> drm/nouveau/kms: Move drm_dp_cec_unset_edid() into nouveau_connector_detect()
> drm/nouveau/kms: Only use hpd_work for reprobing in HPD paths
> drm/i915/dp: Extract drm_dp_read_downstream_info()
> drm/nouveau/kms/nv50-: Use downstream DP clock limits for mode validation
> drm/i915/dp: Extract drm_dp_read_sink_count_cap()
> drm/i915/dp: Extract drm_dp_read_sink_count()
> drm/nouveau/kms/nv50-: Add support for DP_SINK_COUNT
> drm/nouveau/kms: Don't change EDID when it hasn't actually changed
> drm/i915/dp: Extract drm_dp_read_dpcd_caps()
> drm/nouveau/kms: Start using drm_dp_read_dpcd_caps()
>
> drivers/gpu/drm/drm_dp_helper.c | 187 ++++++++++++++++-
> drivers/gpu/drm/drm_dp_mst_topology.c | 22 ++
> drivers/gpu/drm/i915/display/intel_dp.c | 124 +++--------
> drivers/gpu/drm/i915/display/intel_dp.h | 1 -
> drivers/gpu/drm/i915/display/intel_lspcon.c | 2 +-
> drivers/gpu/drm/nouveau/dispnv04/dac.c | 2 +-
> drivers/gpu/drm/nouveau/dispnv04/dfp.c | 7 +-
> drivers/gpu/drm/nouveau/dispnv04/disp.c | 24 ++-
> drivers/gpu/drm/nouveau/dispnv04/disp.h | 4 +
> drivers/gpu/drm/nouveau/dispnv04/tvnv04.c | 2 +-
> drivers/gpu/drm/nouveau/dispnv04/tvnv17.c | 2 +-
> drivers/gpu/drm/nouveau/dispnv50/disp.c | 305 ++++++++++++++++------------
> drivers/gpu/drm/nouveau/nouveau_connector.c | 132 +++++-------
> drivers/gpu/drm/nouveau/nouveau_connector.h | 1 +
> drivers/gpu/drm/nouveau/nouveau_display.c | 72 ++++++-
> drivers/gpu/drm/nouveau/nouveau_display.h | 3 +-
> drivers/gpu/drm/nouveau/nouveau_dp.c | 210 +++++++++++++++----
> drivers/gpu/drm/nouveau/nouveau_drm.c | 4 +-
> drivers/gpu/drm/nouveau/nouveau_drv.h | 2 +
> drivers/gpu/drm/nouveau/nouveau_encoder.h | 48 ++++-
> include/drm/drm_dp_helper.h | 15 +-
> include/drm/drm_dp_mst_helper.h | 3 +-
> 22 files changed, 779 insertions(+), 393 deletions(-)
>
> _______________________________________________
> dri-devel mailing list
> dri-devel at lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/dri-devel
More information about the dri-devel
mailing list