[PATCH 1/2] drm: Rename DP_PSR_SELECTIVE_UPDATE to better mach eDP spec

Mun, Gwan-gyeong gwan-gyeong.mun at intel.com
Thu Apr 22 11:00:02 UTC 2021


The changed name looks more accurate to the edp 1.4b spec.
Looks good to me.

Reviewed-by: Gwan-gyeong Mun <gwan-gyeong.mun at intel.com>

On Wed, 2021-04-21 at 15:02 -0700, José Roberto de Souza wrote:
> DP_PSR_EN_CFG bit 5 aka "Selective Update Region Scan Line Capture
> Indication" in eDP spec has a ambiguous name, so renaming to better
> match specification.
> 
> While at it, replacing bit shit by BIT() macro and adding the version
> some registers were added to eDP specification.
> 
> Cc: <dri-devel at lists.freedesktop.org>
> Cc: Rodrigo Vivi <rodrigo.vivi at intel.com>
> Cc: Jani Nikula <jani.nikula at intel.com>
> Cc: Gwan-gyeong Mun <gwan-gyeong.mun at intel.com>
> Signed-off-by: José Roberto de Souza <jose.souza at intel.com>
> ---
>  include/drm/drm_dp_helper.h | 16 ++++++++--------
>  1 file changed, 8 insertions(+), 8 deletions(-)
> 
> diff --git a/include/drm/drm_dp_helper.h b/include/drm/drm_dp_helper.h
> index 1e85c2021f2f..d6f6a084a190 100644
> --- a/include/drm/drm_dp_helper.h
> +++ b/include/drm/drm_dp_helper.h
> @@ -687,14 +687,14 @@ struct drm_device;
>  #define DP_DSC_ENABLE                       0x160   /* DP 1.4 */
>  # define DP_DECOMPRESSION_EN                (1 << 0)
>  
> -#define DP_PSR_EN_CFG                      0x170   /* XXX 1.2? */
> -# define DP_PSR_ENABLE                     (1 << 0)
> -# define DP_PSR_MAIN_LINK_ACTIVE           (1 << 1)
> -# define DP_PSR_CRC_VERIFICATION           (1 << 2)
> -# define DP_PSR_FRAME_CAPTURE              (1 << 3)
> -# define DP_PSR_SELECTIVE_UPDATE           (1 << 4)
> -# define DP_PSR_IRQ_HPD_WITH_CRC_ERRORS     (1 << 5)
> -# define DP_PSR_ENABLE_PSR2                (1 << 6) /* eDP 1.4a */
> +#define DP_PSR_EN_CFG                          0x170   /* XXX 1.2? */
> +# define DP_PSR_ENABLE                         BIT(0)
> +# define DP_PSR_MAIN_LINK_ACTIVE               BIT(1)
> +# define DP_PSR_CRC_VERIFICATION               BIT(2)
> +# define DP_PSR_FRAME_CAPTURE                  BIT(3)
> +# define DP_PSR_SU_REGION_SCANLINE_CAPTURE     BIT(4) /* eDP 1.4a */
> +# define DP_PSR_IRQ_HPD_WITH_CRC_ERRORS                BIT(5) /* eDP
> 1.4a */
> +# define DP_PSR_ENABLE_PSR2                    BIT(6) /* eDP 1.4a */
>  
>  #define DP_ADAPTER_CTRL                            0x1a0
>  # define DP_ADAPTER_CTRL_FORCE_LOAD_SENSE   (1 << 0)



More information about the dri-devel mailing list