[PATCH v3 0/6] Add Unisoc's drm kms module

Kevin Tang kevin3.tang at gmail.com
Fri Jan 22 16:22:29 UTC 2021


Hi Daniel,
Do you have some more comments for our patch?

Kevin Tang <kevin3.tang at gmail.com> 于2021年1月5日周二 下午9:46写道:

> ChangeList:
> RFC v1:
> 1. only upstream modeset and atomic at first commit.
> 2. remove some unused code;
> 3. use alpha and blend_mode properties;
> 3. add yaml support;
> 4. remove auto-adaptive panel driver;
> 5. bugfix
>
> RFC v2:
> 1. add sprd crtc and plane module for KMS, preparing for multi crtc&encoder
> 2. remove gem drivers, use generic CMA handlers
> 3. remove redundant "module_init", all the sub modules loading by KMS
>
> RFC v3:
> 1. multi crtc&encoder design have problem, so rollback to v1
>
> RFC v4:
> 1. update to gcc-linaro-7.5.0
> 2. update to Linux 5.6-rc3
> 3. remove pm_runtime support
> 4. add COMPILE_TEST, remove unused kconfig
> 5. "drm_dev_put" on drm_unbind
> 6. fix some naming convention issue
> 7. remove semaphore lock for crtc flip
> 8. remove static variables
>
> RFC v5:
> 1. optimize encoder and connector code implementation
> 2. use "platform_get_irq" and "platform_get_resource"
> 3. drop useless function return type, drop unless debug log
> 4. custom properties should be separate, so drop it
> 5. use DRM_XXX replase pr_xxx
> 6. drop dsi&dphy hal callback ops
> 7. drop unless callback ops checking
> 8. add comments for sprd dpu structure
>
> RFC v6:
> 1. Access registers via readl/writel
> 2. Checking for unsupported KMS properties (format, rotation, blend_mode,
> etc) on plane_check ops
> 3. Remove always true checks for dpu core ops
>
> RFC v7:
> 1. Fix DTC unit name warnings
> 2. Fix the problem of maintainers
> 3. Call drmm_mode_config_init to mode config init
> 4. Embed drm_device in sprd_drm and use devm_drm_dev_alloc
> 5. Replace DRM_XXX with drm_xxx on KMS module, but not suitable for other
> subsystems
> 6. Remove plane_update stuff, dpu handles all the HW update in
> crtc->atomic_flush
> 7. Dsi&Dphy Code structure adjustment, all move to "sprd/"
>
> v0:
> 1. Remove dpu_core_ops stuff layer for sprd drtc driver, but dpu_layer
> need to keeping.
>    Because all the HW update in crtc->atomic_flush, we need temporary
> storage all layers for
>    the dpu pageflip of atomic_flush.
> 2. Add ports subnode with port at X.
>
> v1:
> 1. Remove dphy and dsi graph binding, merge the dphy driver into the dsi.
> 2. Add commit messages for Unisoc's virtual nodes.
>
> v2:
> 1. Use drm_xxx to replace all DRM_XXX.
> 2. Use kzalloc to replace devm_kzalloc for sprd_dsi/sprd_dpu structure
> init.
> 3. Remove dpu_core_ops midlayer.
>
> v3:
> 1. Remove dpu_layer midlayer and commit layers by aotmic_update
>
> Kevin Tang (6):
>   dt-bindings: display: add Unisoc's drm master bindings
>   drm/sprd: add Unisoc's drm kms master
>   dt-bindings: display: add Unisoc's dpu bindings
>   drm/sprd: add Unisoc's drm display controller driver
>   dt-bindings: display: add Unisoc's mipi dsi controller bindings
>   drm/sprd: add Unisoc's drm mipi dsi&dphy driver
>
>  .../display/sprd/sprd,display-subsystem.yaml       |   64 +
>  .../bindings/display/sprd/sprd,sharkl3-dpu.yaml    |   77 +
>  .../display/sprd/sprd,sharkl3-dsi-host.yaml        |  102 ++
>  drivers/gpu/drm/Kconfig                            |    2 +
>  drivers/gpu/drm/Makefile                           |    1 +
>  drivers/gpu/drm/sprd/Kconfig                       |   13 +
>  drivers/gpu/drm/sprd/Makefile                      |    8 +
>  drivers/gpu/drm/sprd/dw_dsi_ctrl.c                 |  794 +++++++++++
>  drivers/gpu/drm/sprd/dw_dsi_ctrl.h                 | 1475
> ++++++++++++++++++++
>  drivers/gpu/drm/sprd/dw_dsi_ctrl_ppi.c             |  157 +++
>  drivers/gpu/drm/sprd/dw_dsi_ctrl_ppi.h             |   26 +
>  drivers/gpu/drm/sprd/megacores_pll.c               |  317 +++++
>  drivers/gpu/drm/sprd/megacores_pll.h               |  146 ++
>  drivers/gpu/drm/sprd/sprd_dpu.c                    |  985 +++++++++++++
>  drivers/gpu/drm/sprd/sprd_dpu.h                    |  120 ++
>  drivers/gpu/drm/sprd/sprd_drm.c                    |  224 +++
>  drivers/gpu/drm/sprd/sprd_drm.h                    |   19 +
>  drivers/gpu/drm/sprd/sprd_dsi.c                    | 1162 +++++++++++++++
>  drivers/gpu/drm/sprd/sprd_dsi.h                    |  107 ++
>  19 files changed, 5799 insertions(+)
>  create mode 100644
> Documentation/devicetree/bindings/display/sprd/sprd,display-subsystem.yaml
>  create mode 100644
> Documentation/devicetree/bindings/display/sprd/sprd,sharkl3-dpu.yaml
>  create mode 100644
> Documentation/devicetree/bindings/display/sprd/sprd,sharkl3-dsi-host.yaml
>  create mode 100644 drivers/gpu/drm/sprd/Kconfig
>  create mode 100644 drivers/gpu/drm/sprd/Makefile
>  create mode 100644 drivers/gpu/drm/sprd/dw_dsi_ctrl.c
>  create mode 100644 drivers/gpu/drm/sprd/dw_dsi_ctrl.h
>  create mode 100644 drivers/gpu/drm/sprd/dw_dsi_ctrl_ppi.c
>  create mode 100644 drivers/gpu/drm/sprd/dw_dsi_ctrl_ppi.h
>  create mode 100644 drivers/gpu/drm/sprd/megacores_pll.c
>  create mode 100644 drivers/gpu/drm/sprd/megacores_pll.h
>  create mode 100644 drivers/gpu/drm/sprd/sprd_dpu.c
>  create mode 100644 drivers/gpu/drm/sprd/sprd_dpu.h
>  create mode 100644 drivers/gpu/drm/sprd/sprd_drm.c
>  create mode 100644 drivers/gpu/drm/sprd/sprd_drm.h
>  create mode 100644 drivers/gpu/drm/sprd/sprd_dsi.c
>  create mode 100644 drivers/gpu/drm/sprd/sprd_dsi.h
>
> --
> 2.7.4
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.freedesktop.org/archives/dri-devel/attachments/20210123/32ae41fa/attachment-0001.htm>


More information about the dri-devel mailing list