[PATCH 1/5] drm: Define DRM_FORMAT_MAX_PLANES

Thomas Zimmermann tzimmermann at suse.de
Fri Jul 16 08:50:08 UTC 2021


Hi

Am 16.07.21 um 09:30 schrieb Maxime Ripard:
> Hi,
> 
> On Thu, Jul 15, 2021 at 08:01:29PM +0200, Thomas Zimmermann wrote:
>> DRM uses a magic number of 4 for the maximum number of planes per color
>> format. Declare this constant via DRM_FORMAT_MAX_PLANES and update the
>> related code.
>>
>> Signed-off-by: Thomas Zimmermann <tzimmermann at suse.de>
>> ---
>>   drivers/gpu/drm/drm_gem_framebuffer_helper.c | 14 ++++++++------
>>   include/drm/drm_fourcc.h                     | 13 +++++++++----
>>   include/drm/drm_framebuffer.h                |  8 ++++----
>>   include/drm/drm_gem_atomic_helper.h          |  2 +-
>>   4 files changed, 22 insertions(+), 15 deletions(-)
>>
>> diff --git a/drivers/gpu/drm/drm_gem_framebuffer_helper.c b/drivers/gpu/drm/drm_gem_framebuffer_helper.c
>> index e2c68822e05c..975a3df0561e 100644
>> --- a/drivers/gpu/drm/drm_gem_framebuffer_helper.c
>> +++ b/drivers/gpu/drm/drm_gem_framebuffer_helper.c
>> @@ -48,7 +48,7 @@
>>   struct drm_gem_object *drm_gem_fb_get_obj(struct drm_framebuffer *fb,
>>   					  unsigned int plane)
>>   {
>> -	if (plane >= 4)
>> +	if (plane >= ARRAY_SIZE(fb->obj))
>>   		return NULL;
> 
> This doesn't look related to what's mentionned in the commit log though?
> 
>>   	return fb->obj[plane];
>> @@ -62,7 +62,8 @@ drm_gem_fb_init(struct drm_device *dev,
>>   		 struct drm_gem_object **obj, unsigned int num_planes,
>>   		 const struct drm_framebuffer_funcs *funcs)
>>   {
>> -	int ret, i;
>> +	unsigned int i;
>> +	int ret;
>>   
>>   	drm_helper_mode_fill_fb_struct(dev, fb, mode_cmd);
>>   
>> @@ -86,9 +87,9 @@ drm_gem_fb_init(struct drm_device *dev,
>>    */
>>   void drm_gem_fb_destroy(struct drm_framebuffer *fb)
>>   {
>> -	int i;
>> +	size_t i;
>>   
>> -	for (i = 0; i < 4; i++)
>> +	for (i = 0; i < ARRAY_SIZE(fb->obj); i++)
>>   		drm_gem_object_put(fb->obj[i]);
> 
> Ditto
> 
> Both these changes look fine though, but I guess you should just mention it

Well, good point. I thought it would be cleaner than using 
FORMAT_MAX_PLANES here. I'll leave a note in the commit log.

Best regards
Thomas

> 
> Maxime
> 

-- 
Thomas Zimmermann
Graphics Driver Developer
SUSE Software Solutions Germany GmbH
Maxfeldstr. 5, 90409 Nürnberg, Germany
(HRB 36809, AG Nürnberg)
Geschäftsführer: Felix Imendörffer

-------------- next part --------------
A non-text attachment was scrubbed...
Name: OpenPGP_signature
Type: application/pgp-signature
Size: 840 bytes
Desc: OpenPGP digital signature
URL: <https://lists.freedesktop.org/archives/dri-devel/attachments/20210716/e9e3ece7/attachment.sig>


More information about the dri-devel mailing list