[PATCH 00/30] [Set 1] Rid W=1 warnings in SCSI

Martin K. Petersen martin.petersen at oracle.com
Fri Mar 19 03:46:37 UTC 2021


On Wed, 3 Mar 2021 14:46:01 +0000, Lee Jones wrote:

> This set is part of a larger effort attempting to clean-up W=1
> kernel builds, which are currently overwhelmingly riddled with
> niggly little warnings.
> 
> Lee Jones (30):
>   scsi: megaraid: megaraid_mm: Fix incorrect function name in header
>   scsi: megaraid: megaraid_sas_base: Fix a bunch of misnamed functions
>     in their headers
>   scsi: fcoe: Fix function name fcoe_set_vport_symbolic_name() in
>     description
>   scsi: megaraid: megaraid_mbox: Fix function name
>     megaraid_queue_command_lck() in description
>   scsi: fcoe: fcoe_ctlr: Fix a couple of incorrectly named functions
>   scsi: aic94xx: aic94xx_hwi: Fix a couple of misnamed function names
>   scsi: aacraid: aachba: Fix a few incorrectly named functions
>   scsi: pm8001: pm8001_init: Provide function name and fix a misspelling
>   scsi: aacraid: commctrl: Fix incorrect spelling of aac_send_raw_srb()
>   scsi: bnx2fc: bnx2fc_hwi: Fix typo in bnx2fc_indicate_kcqe()
>   scsi: pm8001: pm8001_sas: Provide function name
>     'pm8001_I_T_nexus_reset()' in header
>   scsi: qla4xxx: ql4_os: Fix formatting issues - missing '-' and '_'
>   scsi: pm8001: pm8001_ctl: Fix incorrectly named functions in headers
>   scsi: aic94xx: aic94xx_sds: Fix asd_erase_nv_sector()'s header
>   scsi: qla2xxx: qla_iocb: Replace __qla2x00_marker()'s missing
>     underscores
>   scsi: aacraid: commsup: Repair formatting issue in
>     aac_handle_sa_aif()'s header
>   scsi: lpfc: lpfc_sli: Fix a bunch of kernel-doc issues
>   scsi: pm8001: pm8001_hwi: Fix some misnamed function descriptions
>   scsi: qla4xxx: ql4_mbx: Fix kernel-doc formatting and misnaming issue
>   scsi: bnx2fc: bnx2fc_tgt: Fix misnaming of bnx2fc_free_session_resc()
>   scsi: aic94xx: aic94xx_dump: Remove code that has been unused for at
>     least 13 years
>   scsi: pm8001: pm80xx_hwi: Fix a bunch of doc-rotted function headers
>   scsi: qla2xxx: qla_gs: Fix some incorrect formatting/spelling issues
>   scsi: aacraid: rx: Fix misspelling of _aac_rx_init()
>   scsi: lpfc: lpfc_ct: Fix formatting and misspelling issues
>   scsi: libfc: fc_lport: Fix some possible copy/paste issues
>   scsi: lpfc: lpfc_hbadisc: Fix incorrect naming of
>     __lpfc_update_fcf_record()
>   scsi: mpt3sas: mpt3sas_base: Fix misspelling of
>     _base_put_smid_default_atomic()
>   scsi: lpfc: lpfc_nportdisc: Fix misspelling of lpfc_defer_acc_rsp()
>   scsi: mpt3sas: mpt3sas_scs: Move a little data from the stack onto the
>     heap
> 
> [...]

Applied to 5.13/scsi-queue, thanks!

[01/30] scsi: megaraid: megaraid_mm: Fix incorrect function name in header
        https://git.kernel.org/mkp/scsi/c/bbb2c0374552
[02/30] scsi: megaraid: megaraid_sas_base: Fix a bunch of misnamed functions in their headers
        https://git.kernel.org/mkp/scsi/c/616f6d8d9e16
[03/30] scsi: fcoe: Fix function name fcoe_set_vport_symbolic_name() in description
        https://git.kernel.org/mkp/scsi/c/276f9aa2530a
[04/30] scsi: megaraid: megaraid_mbox: Fix function name megaraid_queue_command_lck() in description
        https://git.kernel.org/mkp/scsi/c/d4f5ae21597b
[05/30] scsi: fcoe: fcoe_ctlr: Fix a couple of incorrectly named functions
        https://git.kernel.org/mkp/scsi/c/dc173575097f
[06/30] scsi: aic94xx: aic94xx_hwi: Fix a couple of misnamed function names
        https://git.kernel.org/mkp/scsi/c/577c65b07a55
[07/30] scsi: aacraid: aachba: Fix a few incorrectly named functions
        https://git.kernel.org/mkp/scsi/c/a80218c7c565
[08/30] scsi: pm8001: pm8001_init: Provide function name and fix a misspelling
        https://git.kernel.org/mkp/scsi/c/bd1050e13889
[09/30] scsi: aacraid: commctrl: Fix incorrect spelling of aac_send_raw_srb()
        https://git.kernel.org/mkp/scsi/c/4c4b8cf5a109
[10/30] scsi: bnx2fc: bnx2fc_hwi: Fix typo in bnx2fc_indicate_kcqe()
        https://git.kernel.org/mkp/scsi/c/52ffc08d9454
[11/30] scsi: pm8001: pm8001_sas: Provide function name 'pm8001_I_T_nexus_reset()' in header
        https://git.kernel.org/mkp/scsi/c/62690c056ac0
[12/30] scsi: qla4xxx: ql4_os: Fix formatting issues - missing '-' and '_'
        https://git.kernel.org/mkp/scsi/c/ecef0c9e6407
[13/30] scsi: pm8001: pm8001_ctl: Fix incorrectly named functions in headers
        https://git.kernel.org/mkp/scsi/c/3978e59b6d6c
[14/30] scsi: aic94xx: aic94xx_sds: Fix asd_erase_nv_sector()'s header
        https://git.kernel.org/mkp/scsi/c/3528b9abbd06
[15/30] scsi: qla2xxx: qla_iocb: Replace __qla2x00_marker()'s missing underscores
        https://git.kernel.org/mkp/scsi/c/52bb80f18def
[16/30] scsi: aacraid: commsup: Repair formatting issue in aac_handle_sa_aif()'s header
        https://git.kernel.org/mkp/scsi/c/53616df28199
[17/30] scsi: lpfc: lpfc_sli: Fix a bunch of kernel-doc issues
        https://git.kernel.org/mkp/scsi/c/8514e2f1e2c6
[18/30] scsi: pm8001: pm8001_hwi: Fix some misnamed function descriptions
        https://git.kernel.org/mkp/scsi/c/6b87e435e4bc
[19/30] scsi: qla4xxx: ql4_mbx: Fix kernel-doc formatting and misnaming issue
        https://git.kernel.org/mkp/scsi/c/e39c31a7435a
[20/30] scsi: bnx2fc: bnx2fc_tgt: Fix misnaming of bnx2fc_free_session_resc()
        https://git.kernel.org/mkp/scsi/c/a7f4242d1207
[21/30] scsi: aic94xx: aic94xx_dump: Remove code that has been unused for at least 13 years
        https://git.kernel.org/mkp/scsi/c/241b37ac5859
[22/30] scsi: pm8001: pm80xx_hwi: Fix a bunch of doc-rotted function headers
        https://git.kernel.org/mkp/scsi/c/7cdaf12ea50a
[23/30] scsi: qla2xxx: qla_gs: Fix some incorrect formatting/spelling issues
        https://git.kernel.org/mkp/scsi/c/f11c8b42423f
[24/30] scsi: aacraid: rx: Fix misspelling of _aac_rx_init()
        https://git.kernel.org/mkp/scsi/c/7df1daed3330
[25/30] scsi: lpfc: lpfc_ct: Fix formatting and misspelling issues
        https://git.kernel.org/mkp/scsi/c/964bc8c4adb3
[26/30] scsi: libfc: fc_lport: Fix some possible copy/paste issues
        https://git.kernel.org/mkp/scsi/c/4a4db603d0b7
[27/30] scsi: lpfc: lpfc_hbadisc: Fix incorrect naming of __lpfc_update_fcf_record()
        https://git.kernel.org/mkp/scsi/c/3884ce1539b0
[28/30] scsi: mpt3sas: mpt3sas_base: Fix misspelling of _base_put_smid_default_atomic()
        https://git.kernel.org/mkp/scsi/c/e015e0ded135
[29/30] scsi: lpfc: lpfc_nportdisc: Fix misspelling of lpfc_defer_acc_rsp()
        (no commit info)
[30/30] scsi: mpt3sas: mpt3sas_scs: Move a little data from the stack onto the heap
        https://git.kernel.org/mkp/scsi/c/2111ba8781da

-- 
Martin K. Petersen	Oracle Linux Engineering


More information about the dri-devel mailing list