[PATCH v2] drm/msm/dp: delete DP_RECOVERED_CLOCK_OUT_EN to fix tps4
Dmitry Baryshkov
dmitry.baryshkov at linaro.org
Tue Aug 2 06:43:40 UTC 2022
On 01/08/2022 23:13, Kuogee Hsieh wrote:
> Data Symbols scrambled is required for tps4 at link training 2.
> Therefore SCRAMBLING_DISABLE bit should not be set for tps4 to
> work.
> RECOVERED_CLOCK_OUT_EN is for enable simple EYE test for jitter
> measurement with minimal equipment for embedded applications purpose
> and is not required to be set during normal operation.
> Current implementation always have RECOVERED_CLOCK_OUT_EN bit set
> which cause SCRAMBLING_DISABLE bit wrongly set at tps4 which prevent
> tps4 from working.
> This patch delete setting RECOVERED_CLOCK_OUT_EN to fix SCRAMBLING_DISABLE
> be wrongly set at tps4.
Minor nits, more likely concerning feature patches:
- Please insert blank lines between paragraphs, it makes commit message
easier to read. And please add no extra line breaks if you do not intent
to end the paragraph here.
- "This patch" is generally the frowned upon phrase (see
Documentation/process/submitting-patches.rst)
Nevertheless:
Reviewed-by: Dmitry Baryshkov <dmitry.baryshkov at linaro.org>
>
> Changes in v2:
> -- fix Fixes tag
>
> Fixes: c943b4948b58 ("drm/msm/dp: add displayPort driver support")
> Signed-off-by: Kuogee Hsieh <quic_khsieh at quicinc.com>
> ---
> drivers/gpu/drm/msm/dp/dp_ctrl.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/gpu/drm/msm/dp/dp_ctrl.c b/drivers/gpu/drm/msm/dp/dp_ctrl.c
> index ab6aa13..013ca02 100644
> --- a/drivers/gpu/drm/msm/dp/dp_ctrl.c
> +++ b/drivers/gpu/drm/msm/dp/dp_ctrl.c
> @@ -1214,7 +1214,7 @@ static int dp_ctrl_link_train_2(struct dp_ctrl_private *ctrl,
> if (ret)
> return ret;
>
> - dp_ctrl_train_pattern_set(ctrl, pattern | DP_RECOVERED_CLOCK_OUT_EN);
> + dp_ctrl_train_pattern_set(ctrl, pattern);
>
> for (tries = 0; tries <= maximum_retries; tries++) {
> drm_dp_link_train_channel_eq_delay(ctrl->aux, ctrl->panel->dpcd);
--
With best wishes
Dmitry
More information about the dri-devel
mailing list