[PATCH] drm/nouveau/hwmon: use simplified HWMON_CHANNEL_INFO macro
Lyude Paul
lyude at redhat.com
Mon Aug 22 21:58:57 UTC 2022
Reviewed-by: Lyude Paul <lyude at redhat.com>
Thanks! I will push this upstream in a moment
On Mon, 2022-08-15 at 13:40 +0300, Beniamin Sandu wrote:
> This makes the code look cleaner and easier to read.
>
> Signed-off-by: Beniamin Sandu <beniaminsandu at gmail.com>
> ---
> drivers/gpu/drm/nouveau/nouveau_hwmon.c | 85 +++++--------------------
> 1 file changed, 17 insertions(+), 68 deletions(-)
>
> diff --git a/drivers/gpu/drm/nouveau/nouveau_hwmon.c b/drivers/gpu/drm/nouveau/nouveau_hwmon.c
> index 1c3104d20571..a7db7c31064b 100644
> --- a/drivers/gpu/drm/nouveau/nouveau_hwmon.c
> +++ b/drivers/gpu/drm/nouveau/nouveau_hwmon.c
> @@ -211,75 +211,24 @@ static const struct attribute_group temp1_auto_point_sensor_group = {
>
> #define N_ATTR_GROUPS 3
>
> -static const u32 nouveau_config_chip[] = {
> - HWMON_C_UPDATE_INTERVAL,
> - 0
> -};
> -
> -static const u32 nouveau_config_in[] = {
> - HWMON_I_INPUT | HWMON_I_MIN | HWMON_I_MAX | HWMON_I_LABEL,
> - 0
> -};
> -
> -static const u32 nouveau_config_temp[] = {
> - HWMON_T_INPUT | HWMON_T_MAX | HWMON_T_MAX_HYST |
> - HWMON_T_CRIT | HWMON_T_CRIT_HYST | HWMON_T_EMERGENCY |
> - HWMON_T_EMERGENCY_HYST,
> - 0
> -};
> -
> -static const u32 nouveau_config_fan[] = {
> - HWMON_F_INPUT,
> - 0
> -};
> -
> -static const u32 nouveau_config_pwm[] = {
> - HWMON_PWM_INPUT | HWMON_PWM_ENABLE,
> - 0
> -};
> -
> -static const u32 nouveau_config_power[] = {
> - HWMON_P_INPUT | HWMON_P_CAP_MAX | HWMON_P_CRIT,
> - 0
> -};
> -
> -static const struct hwmon_channel_info nouveau_chip = {
> - .type = hwmon_chip,
> - .config = nouveau_config_chip,
> -};
> -
> -static const struct hwmon_channel_info nouveau_temp = {
> - .type = hwmon_temp,
> - .config = nouveau_config_temp,
> -};
> -
> -static const struct hwmon_channel_info nouveau_fan = {
> - .type = hwmon_fan,
> - .config = nouveau_config_fan,
> -};
> -
> -static const struct hwmon_channel_info nouveau_in = {
> - .type = hwmon_in,
> - .config = nouveau_config_in,
> -};
> -
> -static const struct hwmon_channel_info nouveau_pwm = {
> - .type = hwmon_pwm,
> - .config = nouveau_config_pwm,
> -};
> -
> -static const struct hwmon_channel_info nouveau_power = {
> - .type = hwmon_power,
> - .config = nouveau_config_power,
> -};
> -
> static const struct hwmon_channel_info *nouveau_info[] = {
> - &nouveau_chip,
> - &nouveau_temp,
> - &nouveau_fan,
> - &nouveau_in,
> - &nouveau_pwm,
> - &nouveau_power,
> + HWMON_CHANNEL_INFO(chip,
> + HWMON_C_UPDATE_INTERVAL),
> + HWMON_CHANNEL_INFO(temp,
> + HWMON_T_INPUT |
> + HWMON_T_MAX | HWMON_T_MAX_HYST |
> + HWMON_T_CRIT | HWMON_T_CRIT_HYST |
> + HWMON_T_EMERGENCY | HWMON_T_EMERGENCY_HYST),
> + HWMON_CHANNEL_INFO(fan,
> + HWMON_F_INPUT),
> + HWMON_CHANNEL_INFO(in,
> + HWMON_I_INPUT |
> + HWMON_I_MIN | HWMON_I_MAX |
> + HWMON_I_LABEL),
> + HWMON_CHANNEL_INFO(pwm,
> + HWMON_PWM_INPUT | HWMON_PWM_ENABLE),
> + HWMON_CHANNEL_INFO(power,
> + HWMON_P_INPUT | HWMON_P_CAP_MAX | HWMON_P_CRIT),
> NULL
> };
>
--
Cheers,
Lyude Paul (she/her)
Software Engineer at Red Hat
More information about the dri-devel
mailing list