[PATCH v5 2/6] drm/vc4: hdmi: Move clock calculation into its own function
Maxime Ripard
maxime at cerno.tech
Thu Feb 10 09:00:03 UTC 2022
Hi Ville,
Thanks for your review
On Thu, Feb 03, 2022 at 09:59:15PM +0200, Ville Syrjälä wrote:
> > +static int
> > +vc4_hdmi_encoder_compute_clock(const struct vc4_hdmi *vc4_hdmi,
> > + struct vc4_hdmi_connector_state *vc4_state,
> > + const struct drm_display_mode *mode,
> > + unsigned int bpc)
> > +{
> > + unsigned long long clock;
> > +
> > + clock = vc4_hdmi_encoder_compute_mode_clock(mode, bpc);
> > + if (vc4_hdmi_encoder_clock_valid(vc4_hdmi, clock) != MODE_OK)
> > + return -EINVAL;
> > +
> > + vc4_state->pixel_rate = clock;
>
> This thing seems a bit confused between pixels vs. TMDS characters.
> Either that or some/all of the pixel_clock/rate things are just
> misnamed?
Yeah, this is the TMDS characters rate, I'll rename it.
Maxime
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 228 bytes
Desc: not available
URL: <https://lists.freedesktop.org/archives/dri-devel/attachments/20220210/7740481b/attachment.sig>
More information about the dri-devel
mailing list