[PATCH v5 12/13] leds: flashlight: mt6370: Add MediaTek MT6370 flashlight support
Andy Shevchenko
andy.shevchenko at gmail.com
Fri Jul 15 18:13:49 UTC 2022
On Fri, Jul 15, 2022 at 1:29 PM ChiaEn Wu <peterwu.pub at gmail.com> wrote:
> The MediaTek MT6370 is a highly-integrated smart power management IC,
> whichincludes a single cell Li-Ion/Li-Polymer switching battery
which includes
> charger, a USB Type-C & Power Delivery (PD) controller, dual Flash
> LED current sources, a RGB LED driver, a backlight WLED driver,
> a display bias driver and a general LDO for portable devices.
>
> The Flash LED in MT6370 has 2 channel and support torch/strobe mode.
channels
> The commit add the support of MT6370 FLASH LED.
Add the
...
> +#define MT6370_FLCSEN_MASK_ALL (BIT(0) | BIT(1))
GENMASK()
...
> + for (i = 0; i < MT6370_MAX_LEDS; i++) {
> + ret = regmap_update_bits(priv->regmap,
> + MT6370_REG_FLEDISTRB(i),
> + MT6370_ISTROBE_MASK, flevel[i]);
> + if (ret)
> + return ret;
> + }
> + } else {
> + ret = regmap_update_bits(priv->regmap,
> + MT6370_REG_FLEDISTRB(led->led_no),
> + MT6370_ISTROBE_MASK, val);
> + }
> + return ret;
return regmap_update_bits(...);
}
return 0;
...
> + /*
> + * If the flash need to be on,
needs
> + * config the flash current ramping up to the setting value.
> + * Else, always recover back to the minimum one.
> + */
...
> + /* For the flash turn on/off, need to wait HW ramping up/down time
to turn
> + * 5ms/500us to prevent the unexpected problem.
> + */
Wrong multi-line comment style.
> +
No need for a blank line.
> + if (!prev && curr)
> + usleep_range(5000, 6000);
> + else if (prev && !curr)
> + udelay(500);
...
> +static int mt6370_led_register(struct device *parent, struct mt6370_led *led,
> + struct led_init_data *init_data)
> +{
> + struct v4l2_flash_config v4l2_config = {0};
> + int ret;
> +
> + ret = devm_led_classdev_flash_register_ext(parent, &led->flash,
> + init_data);
> + if (ret) {
> + dev_err(parent, "Couldn't register flash %d\n", led->led_no);
> + return ret;
return dev_err_probe() here and everywhere where it is about probe stage.
> + }
> +
> + mt6370_init_v4l2_flash_config(led, &v4l2_config);
> + led->v4l2_flash = v4l2_flash_init(parent, init_data->fwnode,
> + &led->flash, &v4l2_flash_ops,
> + &v4l2_config);
> + if (IS_ERR(led->v4l2_flash)) {
> + dev_err(parent, "Failed to register %d v4l2 sd\n", led->led_no);
> + return PTR_ERR(led->v4l2_flash);
> + }
> +
> + return 0;
> +}
...
> + num = fwnode_property_count_u32(init_data->fwnode, "led-sources");
> + if (num < 1 || num > MT6370_MAX_LEDS) {
> + dev_err(priv->dev,
> + "Not specified or wrong number of led-sources\n");
> + return -EINVAL;
Ditto.
> + }
...
> + ret = fwnode_property_read_u32(init_data->fwnode, "led-max-microamp",
> + &val);
One line?
...
> + val = clamp_align(val, MT6370_STRBTO_MIN_US, MT6370_STRBTO_MAX_US,
> + MT6370_STRBTO_STEP_US);
I would name it mt6370_clamp() to avoid potential collision in the
global namespace in the future.
--
With Best Regards,
Andy Shevchenko
More information about the dri-devel
mailing list