[PATCH 0/2] drm/msm: clean up iommu interface a bit
Dmitry Baryshkov
dmitry.baryshkov at linaro.org
Thu Oct 20 19:31:55 UTC 2022
This series started as an attempt to rework the drivers usage of IOMMU
domains. While the idea ended up to be wrong, these two provide a
sensibly looking cleanup.
Dmitry Baryshkov (2):
drm/msm: remove duplicated code from a6xx_create_address_space
drm/msm: move domain allocation into msm_iommu_new()
drivers/gpu/drm/msm/adreno/a6xx_gmu.c | 7 +++---
drivers/gpu/drm/msm/adreno/a6xx_gpu.c | 31 +++---------------------
drivers/gpu/drm/msm/adreno/adreno_gpu.c | 24 +++++++++---------
drivers/gpu/drm/msm/adreno/adreno_gpu.h | 2 +-
drivers/gpu/drm/msm/disp/mdp4/mdp4_kms.c | 19 ++++++++-------
drivers/gpu/drm/msm/msm_drv.c | 18 ++++++--------
drivers/gpu/drm/msm/msm_iommu.c | 25 ++++++++++++++++---
drivers/gpu/drm/msm/msm_mmu.h | 4 ++-
8 files changed, 63 insertions(+), 67 deletions(-)
--
2.35.1
More information about the dri-devel
mailing list