[PATCH 2/7] drm/msm/dp: Use drm_dp_read_sink_count() helper

Kuogee Hsieh quic_khsieh at quicinc.com
Thu Aug 31 20:27:43 UTC 2023


On 8/29/2023 11:47 AM, Stephen Boyd wrote:
> Use the common function drm_dp_read_sink_count() instead of open-coding
> it. This shrinks the kernel text a tiny bit.
>
> Cc: Vinod Polimera <quic_vpolimer at quicinc.com>
> Cc: Kuogee Hsieh <quic_khsieh at quicinc.com>
> Signed-off-by: Stephen Boyd <swboyd at chromium.org>
Tested-by: Kuogee Hsieh <quic_khsieh at quicinc.com>
Reviewed-by: Kuogee Hsieh <quic_khsieh at quicinc.com>
> ---
>   drivers/gpu/drm/msm/dp/dp_panel.c | 19 +++++++------------
>   1 file changed, 7 insertions(+), 12 deletions(-)
>
> diff --git a/drivers/gpu/drm/msm/dp/dp_panel.c b/drivers/gpu/drm/msm/dp/dp_panel.c
> index 09d4f6c38ef8..a0523b18b9e9 100644
> --- a/drivers/gpu/drm/msm/dp/dp_panel.c
> +++ b/drivers/gpu/drm/msm/dp/dp_panel.c
> @@ -147,8 +147,8 @@ static int dp_panel_update_modes(struct drm_connector *connector,
>   int dp_panel_read_sink_caps(struct dp_panel *dp_panel,
>   	struct drm_connector *connector)
>   {
> -	int rc = 0, bw_code;
> -	int rlen, count;
> +	int rc, bw_code;
> +	int count;
>   	struct dp_panel_private *panel;
>   
>   	if (!dp_panel || !connector) {
> @@ -174,16 +174,11 @@ int dp_panel_read_sink_caps(struct dp_panel *dp_panel,
>   	}
>   
>   	if (dp_panel->dfp_present) {
> -		rlen = drm_dp_dpcd_read(panel->aux, DP_SINK_COUNT,
> -				&count, 1);
> -		if (rlen == 1) {
> -			count = DP_GET_SINK_COUNT(count);
> -			if (!count) {
> -				DRM_ERROR("no downstream ports connected\n");
> -				panel->link->sink_count = 0;
> -				rc = -ENOTCONN;
> -				goto end;
> -			}
> +		count = drm_dp_read_sink_count(panel->aux);
> +		if (!count) {
> +			DRM_ERROR("no downstream ports connected\n");
> +			panel->link->sink_count = 0;
> +			return -ENOTCONN;
>   		}
>   	}
>   


More information about the dri-devel mailing list