[PATCH v4 0/1] Add module oriented dmesg output
John.C.Harrison at Intel.com
John.C.Harrison at Intel.com
Wed Jan 11 20:04:28 UTC 2023
From: John Harrison <John.C.Harrison at Intel.com>
When trying to analyse bug reports from CI, customers, etc. it can be
difficult to work out exactly what is happening on which GT in a
multi-GT system. So add GT oriented debug/error message wrappers. If
used instead of the drm_ equivalents, you get the same output but with
a GT# prefix on it.
This patch set updates the gt/intel_gt*.c files to use the new helpers
as a first step. The intention would be to convert all output messages
throughout the driver as long as they have access to a GT structure.
v2: Go back to using lower case names, add more wrapper sets (combined
review feedback). Also, wrap up probe injection and WARN entries.
v3: Split definitions out to separate header files. Tweak some
messages. Wrap a couple more functions. (review feedback from Jani and
Michal W).
Convert all gt/intel_gt*.c but drop the GuC/HuC/CT files as too much
bikeshedding about formatting.
v4: Re-order some macro definitions (Andi S), update (c) date (Tvrtko)
Signed-off-by: John Harrison <John.C.Harrison at Intel.com>
Reviewed-by: Tvrtko Ursulin <tvrtko.ursulin at intel.com>
John Harrison (1):
drm/i915/gt: Start adding module oriented dmesg output
drivers/gpu/drm/i915/gt/intel_gt.c | 96 +++++++++----------
.../gpu/drm/i915/gt/intel_gt_clock_utils.c | 8 +-
drivers/gpu/drm/i915/gt/intel_gt_irq.c | 9 +-
drivers/gpu/drm/i915/gt/intel_gt_mcr.c | 9 +-
drivers/gpu/drm/i915/gt/intel_gt_pm.c | 9 +-
drivers/gpu/drm/i915/gt/intel_gt_print.h | 51 ++++++++++
drivers/gpu/drm/i915/gt/intel_gt_sysfs.c | 4 +-
drivers/gpu/drm/i915/gt/intel_gt_sysfs_pm.c | 34 ++-----
drivers/gpu/drm/i915/gt/intel_gtt.c | 7 +-
9 files changed, 129 insertions(+), 98 deletions(-)
create mode 100644 drivers/gpu/drm/i915/gt/intel_gt_print.h
--
2.39.0
More information about the dri-devel
mailing list