[PATCH v2 0/3] drm/msm/mdss: rework UBWC setup
Dmitry Baryshkov
dmitry.baryshkov at linaro.org
Wed Jan 18 01:04:25 UTC 2023
The commit 92bab9142456 ("drm/msm: less magic numbers in
msm_mdss_enable") reworked the static UBWC setup to replace magic
numbers with calulating written values from the SoC/device parameters.
This simplified adding new platforms.
However I did not estimate that the values would still be cryptic and
would be C&P-sted instead of being determined from the vendor DT. Some
of the platform (sc8180x) completely missed this setup step.
This series attempts to rework the static UBWC setup to be both
manageable and hopefully easier to write.
Changes since RFC:
- Merged sm6115 fixup patch into the main patch, since only the comment
was incorrect
- Moved reading HW revision and UBWC decoder version to the error case
only
Dmitry Baryshkov (3):
drm/msm/mdss: convert UBWC setup to use match data
drm/msm/mdss: add data for sc8180xp
drm/msm/mdss: add the sdm845 data for completeness
drivers/gpu/drm/msm/msm_mdss.c | 198 ++++++++++++++++++++-------------
1 file changed, 120 insertions(+), 78 deletions(-)
--
2.39.0
More information about the dri-devel
mailing list