[PATCH RFC v1 52/52] drm/crtc: Complete renaming struct drm_crtc::dev to drm_dev
Uwe Kleine-König
u.kleine-koenig at pengutronix.de
Wed Jul 12 09:47:02 UTC 2023
Now that all drivers use the new and better name, the old one can be
dropped.
Signed-off-by: Uwe Kleine-König <u.kleine-koenig at pengutronix.de>
---
include/drm/drm_crtc.h | 10 +---------
1 file changed, 1 insertion(+), 9 deletions(-)
diff --git a/include/drm/drm_crtc.h b/include/drm/drm_crtc.h
index 66b65108024e..33a6e90f8d19 100644
--- a/include/drm/drm_crtc.h
+++ b/include/drm/drm_crtc.h
@@ -936,15 +936,7 @@ struct drm_crtc_funcs {
*/
struct drm_crtc {
/** @drm_dev: parent DRM device */
- union {
- /* "dev" is a name that is typically (only) used for struct
- * device pointers. It's about to be renamed to "drm_dev" to be
- * easier to parse for humans. To not have to convert all
- * drivers in a single step keep the old name around for now.
- */
- struct drm_device *drm_dev;
- struct drm_device *dev;
- };
+ struct drm_device *drm_dev;
/** @port: OF node used by drm_of_find_possible_crtcs(). */
struct device_node *port;
/**
--
2.39.2
More information about the dri-devel
mailing list