[EXT] Re: [PATCH v7 3/7] dt-bindings: display: bridge: Add Cadence MHDP850

Rob Herring robh at kernel.org
Tue Jul 18 22:32:08 UTC 2023


On Tue, Jul 18, 2023 at 01:58:09AM +0000, Sandor Yu wrote:
> Hi Alexander,
> 
> Thanks for your comments,
> 
> >
> > Am Montag, 17. Juli 2023, 10:03:49 CEST schrieb Sandor Yu:
> > > ********************
> > > Achtung externe E-Mail: Öffnen Sie Anhänge und Links nur, wenn Sie
> > > wissen, dass diese aus einer sicheren Quelle stammen und sicher sind.
> > > Leiten Sie die E-Mail im Zweifelsfall zur Prüfung an den IT-Helpdesk weiter.
> > > Attention external email: Open attachments and links only if you know
> > > that they are from a secure source and are safe. In doubt forward the
> > > email to the IT-Helpdesk to check it. ********************
> > >
> > > Add bindings for Cadence MHDP8501 DisplayPort/HDMI bridge..
> > >
> > > Signed-off-by: Sandor Yu <Sandor.yu at nxp.com>
> > > ---
> > >  .../display/bridge/cdns,mhdp8501.yaml         | 105
> > ++++++++++++++++++
> > >  1 file changed, 105 insertions(+)
> > >  create mode 100644
> > > Documentation/devicetree/bindings/display/bridge/cdns,mhdp8501.yaml
> > >
> > > diff --git
> > > a/Documentation/devicetree/bindings/display/bridge/cdns,mhdp8501.yaml
> > > b/Documentation/devicetree/bindings/display/bridge/cdns,mhdp8501.yaml
> > > new file mode 100644 index 000000000000..b983ee765f54
> > > --- /dev/null
> > > +++
> > b/Documentation/devicetree/bindings/display/bridge/cdns,mhdp8501.y
> > > +++ aml
> > > @@ -0,0 +1,105 @@
> > > +# SPDX-License-Identifier: (GPL-2.0 OR BSD-2-Clause) %YAML 1.2
> > > +---
> > > +$id:
> > > +http://devi/
> > >
> > +cetree.org%2Fschemas%2Fdisplay%2Fbridge%2Fcdns%2Cmhdp8501.yaml%
> > 23&dat
> > >
> > +a=05%7C01%7CSandor.yu%40nxp.com%7C603a90f3f3c34d32a1e708db86a
> > 8f868%7C
> > >
> > +686ea1d3bc2b4c6fa92cd99c5c301635%7C0%7C0%7C63825183250590544
> > 2%7CUnkno
> > >
> > +wn%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1
> > haWwi
> > >
> > +LCJXVCI6Mn0%3D%7C3000%7C%7C%7C&sdata=JnbufeZplo%2B6JGW4HaK
> > %2BLyC0MESK
> > > +GsV%2FtjfeXCXqK4U%3D&reserved=0
> > > +$schema:
> > > +http://devi/
> > >
> > +cetree.org%2Fmeta-schemas%2Fcore.yaml%23&data=05%7C01%7CSandor.
> > yu%40n
> > >
> > +xp.com%7C603a90f3f3c34d32a1e708db86a8f868%7C686ea1d3bc2b4c6fa9
> > 2cd99c5
> > >
> > +c301635%7C0%7C0%7C638251832505905442%7CUnknown%7CTWFpbGZs
> > b3d8eyJWIjoi
> > >
> > +MC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3
> > 000%7C%
> > >
> > +7C%7C&sdata=rdOyjVz4gGnToVC40Rcfp%2Fk925yC%2F6xNwGbBAnOtcDQ
> > %3D&reserv
> > > +ed=0
> > > +
> > > +title: Cadence MHDP8501 DP/HDMI bridge
> > > +
> > > +maintainers:
> > > +  - Sandor Yu <Sandor.yu at nxp.com>
> > > +
> > > +description:
> > > +  Cadence MHDP8501 DisplayPort/HDMI interface.
> > > +
> > > +properties:
> > > +  compatible:
> > > +    enum:
> > > +      - cdns,mhdp8501
> > > +      - fsl,imx8mq-mhdp8501
> > > +
> > > +  reg:
> > > +    maxItems: 1
> > > +
> > > +  clocks:
> > > +    maxItems: 1
> > > +    description: MHDP8501 DP/HDMI APB clock.
> > > +
> > > +  phys:
> > > +    maxItems: 1
> > > +    description:
> > > +      phandle to the DisplayPort or HDMI PHY
> > > +
> > > +  interrupts:
> > > +    items:
> > > +      - description: Hotplug cable plugin.
> > > +      - description: Hotplug cable plugout.
> > > +
> > > +  interrupt-names:
> > > +    items:
> > > +      - const: plug_in
> > > +      - const: plug_out
> > > +
> > > +  ports:
> > > +    $ref: /schemas/graph.yaml#/properties/ports
> > > +
> > > +    properties:
> > > +      port at 0:
> > > +        $ref: /schemas/graph.yaml#/properties/port
> > > +        description:
> > > +          Input port from display controller output.
> > > +      port at 1:
> > > +        $ref: /schemas/graph.yaml#/properties/port
> > > +        description:
> > > +          Output port to DisplayPort or HDMI connector.
> > > +
> > > +    required:
> > > +      - port at 0
> > > +      - port at 1
> > > +
> > > +required:
> > > +  - compatible
> > > +  - reg
> > > +  - clocks
> > > +  - interrupts
> > > +  - interrupt-names
> > > +  - phys
> > > +  - ports
> > > +
> > > +additionalProperties: false
> > > +
> > > +examples:
> > > +  - |
> > > +    #include <dt-bindings/clock/imx8mq-clock.h>
> > > +    #include <dt-bindings/interrupt-controller/arm-gic.h>
> > > +
> > > +    mhdp_dp: dp-bridge at 32c00000 {
> >
> > I'm not sure, but I would name this node just 'bridge', because it can be either
> > DP or HDMI depending on the connector. But DT folks will know better than
> > me.
> This name should update too after DP and HDMI driver combined.

Has nothing to do with a driver.

> I will change to "mhdp: mhdp-bridge at 32c00000" in the next version.

What is 'mhdp'? Doesn't sound generic. Use just 'bridge' or 
'display-bridge'. We don't have a standard name defined in the DT spec 
(there's 'hdmi', but nothing that's protocol independent).

Rob


More information about the dri-devel mailing list