[PATCH 07/13] pagevec: Rename fbatch_count()
Matthew Wilcox (Oracle)
willy at infradead.org
Wed Jun 21 16:45:51 UTC 2023
This should always have been called folio_batch_count().
Signed-off-by: Matthew Wilcox (Oracle) <willy at infradead.org>
---
include/linux/pagevec.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/include/linux/pagevec.h b/include/linux/pagevec.h
index 42aad53e382e..3a9d29dd28a3 100644
--- a/include/linux/pagevec.h
+++ b/include/linux/pagevec.h
@@ -105,7 +105,7 @@ static inline unsigned int folio_batch_count(struct folio_batch *fbatch)
return fbatch->nr;
}
-static inline unsigned int fbatch_space(struct folio_batch *fbatch)
+static inline unsigned int folio_batch_space(struct folio_batch *fbatch)
{
return PAGEVEC_SIZE - fbatch->nr;
}
@@ -124,7 +124,7 @@ static inline unsigned folio_batch_add(struct folio_batch *fbatch,
struct folio *folio)
{
fbatch->folios[fbatch->nr++] = folio;
- return fbatch_space(fbatch);
+ return folio_batch_space(fbatch);
}
static inline void __folio_batch_release(struct folio_batch *fbatch)
--
2.39.2
More information about the dri-devel
mailing list