[PATCH] drm/amd/display: Use swap() instead of open coding it

Hamza Mahfooz hamza.mahfooz at amd.com
Thu Mar 9 15:03:58 UTC 2023


On 3/8/23 21:52, Jiapeng Chong wrote:
> Swap is a function interface that provides exchange function. To avoid
> code duplication, we can use swap function.
> 
> ./drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c:359:57-58: WARNING opportunity for swap().
> 
> Reported-by: Abaci Robot <abaci at linux.alibaba.com>
> Link: https://bugzilla.openanolis.cn/show_bug.cgi?id=4448
> Signed-off-by: Jiapeng Chong <jiapeng.chong at linux.alibaba.com>

Applied, thanks!

> ---
>   drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c | 8 ++------
>   1 file changed, 2 insertions(+), 6 deletions(-)
> 
> diff --git a/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c b/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c
> index ae994c6c65ac..f6d9bbce15b2 100644
> --- a/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c
> +++ b/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c
> @@ -352,13 +352,9 @@ static inline void reverse_planes_order(struct dc_surface_update *array_of_surfa
>   					int planes_count)
>   {
>   	int i, j;
> -	struct dc_surface_update surface_updates_temp;
>   
> -	for (i = 0, j = planes_count - 1; i < j; i++, j--) {
> -		surface_updates_temp = array_of_surface_update[i];
> -		array_of_surface_update[i] = array_of_surface_update[j];
> -		array_of_surface_update[j] = surface_updates_temp;
> -	}
> +	for (i = 0, j = planes_count - 1; i < j; i++, j--)
> +		swap(array_of_surface_update[i], array_of_surface_update[j]);
>   }
>   
>   /**

-- 
Hamza



More information about the dri-devel mailing list