[v2,24/50] drm/msm/dpu: split QCM2290 catalog entry to the separate file
Dmitry Baryshkov
dmitry.baryshkov at linaro.org
Thu Mar 30 11:52:45 UTC 2023
On 30/03/2023 14:50, Konrad Dybcio wrote:
>
>
> On 12.02.2023 00:12, Dmitry Baryshkov wrote:
>> Signed-off-by: Dmitry Baryshkov <dmitry.baryshkov at linaro.org>
>> ---
>> .../msm/disp/dpu1/catalog/dpu_6_5_qcm2290.h | 116 ++++++++++++++++++
>> .../gpu/drm/msm/disp/dpu1/dpu_hw_catalog.c | 108 +---------------
>> 2 files changed, 117 insertions(+), 107 deletions(-)
>> create mode 100644 drivers/gpu/drm/msm/disp/dpu1/catalog/dpu_6_5_qcm2290.h
>>
>> diff --git a/drivers/gpu/drm/msm/disp/dpu1/catalog/dpu_6_5_qcm2290.h b/drivers/gpu/drm/msm/disp/dpu1/catalog/dpu_6_5_qcm2290.h
>> new file mode 100644
>> index 000000000000..48e7d4c641cd
>> --- /dev/null
>> +++ b/drivers/gpu/drm/msm/disp/dpu1/catalog/dpu_6_5_qcm2290.h
>> @@ -0,0 +1,116 @@
>> +/* SPDX-License-Identifier: GPL-2.0-only */
>> +/*
>> + * Copyright (c) 2022. Qualcomm Innovation Center, Inc. All rights reserved.
>> + * Copyright (c) 2015-2018, 2020 The Linux Foundation. All rights reserved.
>> + */
>> +
>> +#ifndef _DPU_6_5_QCM2290_H
>> +#define _DPU_6_5_QCM2290_H
>> +
>> +static const struct dpu_caps qcm2290_dpu_caps = {
>> + .max_mixer_width = DEFAULT_DPU_LINE_WIDTH,
>> + .max_mixer_blendstages = 0x4,
>> + .smart_dma_rev = DPU_SSPP_SMART_DMA_V2,
> Rebase
Yes, I will rebase before sending next iteration
>
>> + .has_dim_layer = true,
>> + .has_idle_pc = true,
>> + .max_linewidth = 2160,
>> + .pixel_ram_size = DEFAULT_PIXEL_RAM_SIZE,
>> +};
>> +
>
> [...]
>
>> +#include "catalog/dpu_6_5_qcm2290.h"
>> #include "catalog/dpu_6_3_sm6115.h"
> I will not ask you to do redo it now, as it will mess with 50 patches
> (unless you fix that in the following ones that I didn't get to yet),
> but please rename qcm2290 things to sm6115 or whatever the case may be
> so that we can keep the dpu_x_y_abcd sorted.
This is fixed in patch 42. The intention here was only to move date
without changing it.
>
> With that:
>
> Reviewed-by: Konrad Dybcio <konrad.dybcio at linaro.org>
>
> Konrad
>>
>> #include "catalog/dpu_7_0_sm8350.h"
--
With best wishes
Dmitry
More information about the dri-devel
mailing list