[PATCH 4/5] accel/ivpu: Rename and cleanup MMU600 page tables

Jeffrey Hugo quic_jhugo at quicinc.com
Thu May 18 14:11:22 UTC 2023


On 5/18/2023 7:16 AM, Stanislaw Gruszka wrote:
> From: Karol Wachowski <karol.wachowski at linux.intel.com>
> 
> Simplify and unify naming convention in MMU600 page tables
> configuration.
> 
> All DMA addresses in page tables directly accessed by VPU are called
> with _dma sufix and all CPU pointers to those page tables have _ptr
> sufix.
> 
> Base pointers used to do a page walk on the CPU have corresponding
> names:
> 
>   pud_ptrs (pointers used to get access to PUD DMA)
>   pmd_ptrs (pointers used to get access to PMD DMA)
>   pte_ptrs (pointers used to get access to PTE DMA)
> 
> with the following convention:
> 
>   u64 *pud_dma_ptr = pud_ptrs[pgd_idx];
>   *pud_dma_ptr = pud_dma;
> 
>   u64 *pmd_dma_ptr = pmd_ptrs[pgd_idx][pud_idx];
>   *pmd_dma_ptr = pmd_dma;
> 
>   u64 *pte_dma_ptr = pte_ptrs[pgd_idx][pud_idx][pmd_idx];
>   *pte_dma_ptr = pte_dma;
> 
> On the way change to coherent dma allocation, _wc is only valid on ARM
> and was used by mistake.
> 
> Signed-off-by: Karol Wachowski <karol.wachowski at linux.intel.com>
> Reviewed-by: Stanislaw Gruszka <stanislaw.gruszka at linux.intel.com>
> Signed-off-by: Stanislaw Gruszka <stanislaw.gruszka at linux.intel.com>

Reviewed-by: Jeffrey Hugo <quic_jhugo at quicinc.com>


More information about the dri-devel mailing list