[PATCH 07/12] drm/ast: Rename AST_IO_DAC_DATA to AST_IO_VGAPDR

Thomas Zimmermann tzimmermann at suse.de
Tue Oct 17 08:32:03 UTC 2023


Rename AST_IO_DAC_DATA to AST_IO_VGAPDR to align naming
in the driver with documentation. No functional changes.

Signed-off-by: Thomas Zimmermann <tzimmermann at suse.de>
---
 drivers/gpu/drm/ast/ast_drv.h  | 2 +-
 drivers/gpu/drm/ast/ast_mode.c | 6 +++---
 2 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/drivers/gpu/drm/ast/ast_drv.h b/drivers/gpu/drm/ast/ast_drv.h
index 2b46fafd3467f..43d1861d62624 100644
--- a/drivers/gpu/drm/ast/ast_drv.h
+++ b/drivers/gpu/drm/ast/ast_drv.h
@@ -265,7 +265,7 @@ static inline bool __ast_gen_is_eq(struct ast_device *ast, unsigned long gen)
 #define AST_IO_VGASRI			(0x44)
 #define AST_IO_VGADRR			(0x47)
 #define AST_IO_VGADWR			(0x48)
-#define AST_IO_DAC_DATA		        (0x49)
+#define AST_IO_VGAPDR		        (0x49)
 #define AST_IO_GR_PORT			(0x4E)
 #define AST_IO_CRTC_PORT		(0x54)
 #define AST_IO_INPUT_STATUS1_READ	(0x5A)
diff --git a/drivers/gpu/drm/ast/ast_mode.c b/drivers/gpu/drm/ast/ast_mode.c
index a719f6c9493dc..fa21cdfd6c4f5 100644
--- a/drivers/gpu/drm/ast/ast_mode.c
+++ b/drivers/gpu/drm/ast/ast_mode.c
@@ -57,11 +57,11 @@ static inline void ast_load_palette_index(struct ast_device *ast,
 {
 	ast_io_write8(ast, AST_IO_VGADWR, index);
 	ast_io_read8(ast, AST_IO_VGASRI);
-	ast_io_write8(ast, AST_IO_DAC_DATA, red);
+	ast_io_write8(ast, AST_IO_VGAPDR, red);
 	ast_io_read8(ast, AST_IO_VGASRI);
-	ast_io_write8(ast, AST_IO_DAC_DATA, green);
+	ast_io_write8(ast, AST_IO_VGAPDR, green);
 	ast_io_read8(ast, AST_IO_VGASRI);
-	ast_io_write8(ast, AST_IO_DAC_DATA, blue);
+	ast_io_write8(ast, AST_IO_VGAPDR, blue);
 	ast_io_read8(ast, AST_IO_VGASRI);
 }
 
-- 
2.42.0



More information about the dri-devel mailing list