[PATCH v7 0/3] drm: Use full allocated minor range for DRM
Christian König
christian.koenig at amd.com
Mon Aug 26 18:07:43 UTC 2024
Am 23.08.24 um 18:30 schrieb Michał Winiarski:
> 64 DRM device nodes is not enough for everyone.
> Upgrade it to ~512K (which definitely is more than enough).
>
> Additionally, convert minors to use XArray instead of IDR to simplify
> the locking.
>
> Corresponding libdrm changes were merged in:
> https://gitlab.freedesktop.org/mesa/drm/-/merge_requests/305
Added my Acked-by and pushed the result to drm-misc-next.
Regards,
Christian.
>
> v1 -> v2:
> Don't touch DRM_MINOR_CONTROL and its range (Simon Ser)
>
> v2 -> v3:
> Don't use legacy scheme for >=192 minor range (Dave Airlie)
> Add modparam for testing (Dave Airlie)
> Add lockdep annotation for IDR (Daniel Vetter)
>
> v3 -> v4:
> Convert from IDR to XArray (Matthew Wilcox)
>
> v4 -> v5:
> Fixup IDR to XArray conversion (Matthew Wilcox)
>
> v5 -> v6:
> Also convert Accel to XArray
> Rename skip_legacy_minors to force_extended_minors
>
> v6 -> v7:
> Drop the force_extended_minors patch intended for debug
> Rebase on latest drm-tip
> Update the cover letter, pointing out libdrm changes
>
> Michał Winiarski (3):
> drm: Use XArray instead of IDR for minors
> accel: Use XArray instead of IDR for minors
> drm: Expand max DRM device number to full MINORBITS
>
> drivers/accel/drm_accel.c | 110 +++------------------------------
> drivers/gpu/drm/drm_drv.c | 97 ++++++++++++++---------------
> drivers/gpu/drm/drm_file.c | 2 +-
> drivers/gpu/drm/drm_internal.h | 4 --
> include/drm/drm_accel.h | 18 +-----
> include/drm/drm_file.h | 5 ++
> 6 files changed, 62 insertions(+), 174 deletions(-)
>
More information about the dri-devel
mailing list