[PATCH 11/15] RDMA/hbl: add habanalabs RDMA driver
Jason Gunthorpe
jgg at ziepe.ca
Fri Jul 12 13:08:56 UTC 2024
On Fri, Jun 28, 2024 at 10:24:32AM +0000, Omer Shpigelman wrote:
> We need the core driver to access the IB driver (and to the ETH driver as
> well). As you wrote, we can't use exported symbols from our IB driver nor
> rely on function pointers, but what about providing the core driver an ops
> structure? meaning exporting a register function from the core driver that
> should be called by the IB driver during auxiliary device probe.
> Something like:
>
> int hbl_cn_register_ib_aux_dev(struct auxiliary_device *adev,
> struct hbl_ib_ops *ops)
> {
> ...
> }
> EXPORT_SYMBOL(hbl_cn_register_ib_aux_dev);
Definately do not do some kind of double-register like this.
The auxiliary_device scheme can already be extended to provide ops for
each sub device.
Like
struct habana_driver {
struct auxiliary_driver base;
const struct habana_ops *ops;
};
If the ops are justified or not is a different question.
> module reference counter. But we also get the ability to access the IB
> driver from the core driver (to report a HW error for example).
Report a HW error seems reasonable to me
Other driver have used notifier chains for this kind of stuff though.
Jason
More information about the dri-devel
mailing list