[PATCH] drm/scheduler: Use ternary operator in standardized manner
Jani Nikula
jani.nikula at linux.intel.com
Wed Jul 24 07:34:10 UTC 2024
On Mon, 15 Jul 2024, Philipp Stanner <pstanner at redhat.com> wrote:
> drm_sched_init() omits the middle operand when using the ternary
> operator to set the timeout_wq if one has been passed.
>
> This is a non-standardized GNU extension to the C language [1].
>
> It decreases code readability and might be read as a bug. Furthermore,
> it is not consistent with all other places in drm/scheduler where the
> ternary operator is used.
>
> Replace the expression with the standard one.
The GCC extension is widely used in the kernel for brevity. Arguably
duplicating the first operand is more error prone than omitting it.
Consistency within scheduler may be a valid point, but I'd consider
removing the redundant middle operand instead.
BR,
Jani.
>
> [1] https://gcc.gnu.org/onlinedocs/gcc-14.1.0/gcc/Conditionals.html
>
> Suggested-by: Marco Pagani <marpagan at redhat.com>
> Signed-off-by: Philipp Stanner <pstanner at redhat.com>
> ---
> drivers/gpu/drm/scheduler/sched_main.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/gpu/drm/scheduler/sched_main.c b/drivers/gpu/drm/scheduler/sched_main.c
> index 7e90c9f95611..02cf9c37a232 100644
> --- a/drivers/gpu/drm/scheduler/sched_main.c
> +++ b/drivers/gpu/drm/scheduler/sched_main.c
> @@ -1257,7 +1257,7 @@ int drm_sched_init(struct drm_gpu_scheduler *sched,
> sched->credit_limit = credit_limit;
> sched->name = name;
> sched->timeout = timeout;
> - sched->timeout_wq = timeout_wq ? : system_wq;
> + sched->timeout_wq = timeout_wq ? timeout_wq : system_wq;
> sched->hang_limit = hang_limit;
> sched->score = score ? score : &sched->_score;
> sched->dev = dev;
--
Jani Nikula, Intel
More information about the dri-devel
mailing list