[PATCH v3 02/10] drm/bridge: cdns-dsi: Fix the phy_initialized variable

Aradhya Bhatia a-bhatia1 at ti.com
Mon Jun 17 14:16:08 UTC 2024


Hi Dmitry,

Thanks for reviewing the patches!

On 17/06/24 17:29, Dmitry Baryshkov wrote:
> On Mon, Jun 17, 2024 at 04:23:03PM GMT, Aradhya Bhatia wrote:
>> Update the Phy initialized state to "not initialized" when the driver
>> (and the hardware by extension) gets suspended. This will allow the Phy
>> to get initialized again after resume.
>>
>> Fixes: e19233955d9e ("drm/bridge: Add Cadence DSI driver")
>> Signed-off-by: Aradhya Bhatia <a-bhatia1 at ti.com>
>> ---
>>  drivers/gpu/drm/bridge/cadence/cdns-dsi-core.c | 1 +
>>  1 file changed, 1 insertion(+)
>>
>> diff --git a/drivers/gpu/drm/bridge/cadence/cdns-dsi-core.c b/drivers/gpu/drm/bridge/cadence/cdns-dsi-core.c
>> index b016f2ba06bb..42565e253b2d 100644
>> --- a/drivers/gpu/drm/bridge/cadence/cdns-dsi-core.c
>> +++ b/drivers/gpu/drm/bridge/cadence/cdns-dsi-core.c
>> @@ -1153,6 +1153,7 @@ static int __maybe_unused cdns_dsi_suspend(struct device *dev)
>>  	clk_disable_unprepare(dsi->dsi_p_clk);
>>  	reset_control_assert(dsi->dsi_p_rst);
>>  	dsi->link_initialized = false;
> 
> Most likely you should also call phy_exit() here. And in _remove() too.

I agree that phy_exit should be called here. But why in _remove()?
Wouldn't having phy_exit in 2 places mess up the internal ref count?

> 
>> +	dsi->phy_initialized = false;
>>  	return 0;
>>  }
>>  
>> -- 
>> 2.34.1
>>
> 
--
Regards
Aradhya


More information about the dri-devel mailing list