[PATCH v4 03/14] drm/mediatek: Rename "mtk_drm_plane" to "mtk_plane"
AngeloGioacchino Del Regno
angelogioacchino.delregno at collabora.com
Fri Mar 22 08:46:33 UTC 2024
Il 22/03/24 02:27, Shawn Sung ha scritto:
> From: Hsiao Chien Sung <shawn.sung at mediatek.corp-partner.google.com>
>
> Rename all "mtk_drm_plane" to "mtk_plane":
> - To align the naming rule
> - To reduce the code size
>
> Reviewed-by: AngeloGiaocchino Del Regno <angelogioacchino.delregno at collabora.com>
Shawn - please - can you fix my typo'ed name also here and on all of the
patches of this series?
Thanks.
> Reviewed-by: CK Hu <ck.hu at mediatek.com>
> Signed-off-by: Hsiao Chien Sung <shawn.sung at mediatek.corp-partner.google.com>
> ---
> drivers/gpu/drm/mediatek/mtk_drm_plane.c | 6 +++---
> drivers/gpu/drm/mediatek/mtk_drm_plane.h | 4 ++--
> 2 files changed, 5 insertions(+), 5 deletions(-)
>
> diff --git a/drivers/gpu/drm/mediatek/mtk_drm_plane.c b/drivers/gpu/drm/mediatek/mtk_drm_plane.c
> index cbdb70677d305..43137c46fc148 100644
> --- a/drivers/gpu/drm/mediatek/mtk_drm_plane.c
> +++ b/drivers/gpu/drm/mediatek/mtk_drm_plane.c
> @@ -93,8 +93,8 @@ static bool mtk_plane_format_mod_supported(struct drm_plane *plane,
> return true;
> }
>
> -static void mtk_drm_plane_destroy_state(struct drm_plane *plane,
> - struct drm_plane_state *state)
> +static void mtk_plane_destroy_state(struct drm_plane *plane,
> + struct drm_plane_state *state)
> {
> __drm_atomic_helper_plane_destroy_state(state);
> kfree(to_mtk_plane_state(state));
> @@ -241,7 +241,7 @@ static const struct drm_plane_funcs mtk_plane_funcs = {
> .destroy = drm_plane_cleanup,
> .reset = mtk_plane_reset,
> .atomic_duplicate_state = mtk_plane_duplicate_state,
> - .atomic_destroy_state = mtk_drm_plane_destroy_state,
> + .atomic_destroy_state = mtk_plane_destroy_state,
> .format_mod_supported = mtk_plane_format_mod_supported,
> };
>
> diff --git a/drivers/gpu/drm/mediatek/mtk_drm_plane.h b/drivers/gpu/drm/mediatek/mtk_drm_plane.h
> index 99aff7da0831d..231bb7aac9473 100644
> --- a/drivers/gpu/drm/mediatek/mtk_drm_plane.h
> +++ b/drivers/gpu/drm/mediatek/mtk_drm_plane.h
> @@ -4,8 +4,8 @@
> * Author: CK Hu <ck.hu at mediatek.com>
> */
>
> -#ifndef _MTK_DRM_PLANE_H_
> -#define _MTK_DRM_PLANE_H_
> +#ifndef _MTK_PLANE_H_
> +#define _MTK_PLANE_H_
>
> #include <drm/drm_crtc.h>
> #include <linux/types.h>
More information about the dri-devel
mailing list